Dome Leak Sensor (DMWS1)

Tags: #<Tag:0x00007f74601ac238>

Hello,

I have just purchased a Z-Wave Plus Dome Leak Sensor Link. I have spent the last 2 weeks trying to get it recognized. Knowing that this is a battery powered device and it will take some time to initiate, I have placed the sensor near the controller, but with no luck. PaperUI is showing it as “Unknown Device”. Things I have tried:

  • Updated to 2.5.0.M3 (was running 2.4.0)
  • Restarted OpenHAB a number of times.
  • Manually wake up the device dozens of times (with ~10-15 sec pause in between).
  • Exclude/Include the device half a dozen times.

My setup:

  • Windows 10
  • Java Version 8 Update 221
  • Controller is a Aeotec’s Z-Stick Gen5.
  • Device is Node 27.

Here is the log file: Z-Wave Log File

Any help is much appreciated. Thanks!

In the userdata zwave folder there should be an xml file generated for that node. Posting it would be helpful.
Since zwave devices are region-specific we may need to add some identification to the database.

I added one of these to my network quite a while ago, so I’m confident you’ll get it working.

It’s a nice device. I have it under my kitchen sink. It saved my butt by detecting a slow leak that would’ve caused a lot of damage over time if not detected.

There’s very little in the log file for node 27. It doesn’t look like the device is waking up at all. Perhaps check the procedure you’re using to wake it up?

From out database:

1 Like

Thank you for everyone’s feedback!!

@Bruce_Osborne Interestingly, there is no XML file for this node (Node 27) in the folder. See screenshot.

@mhilbush Thanks for the information. I have followed the manufacturer’s procedure to wake up the device, which is the same as the database. The procedure seems fairly straightforward. I have the z-wave controller ~0.5 meter away. See video Link

The device appears to be functional (i.e. not broken). The LED behavior matches the manual’s description whenever I wake up the device, preforms a factory reset, or include/exclude it to the network. Also, the alarm works when it detects water.

Side note: I found this post Link after some additional research. It appears the Samsung SmartThings can also have trouble recognizing this device, and requires manual configuration.

Thanks in advance for any additional help or ideas you can offer!

If there is no xml file it has not been fully discovered by the binding. This is quite common with battery powered devices. When adding as a Thing the device needs to be kept awake until the initial discovery is complete. I believe if you use HABmin you can see the discovery progress by looking at the Thing status.

On mine, the 2 second press-and-hold doesn’t wake up the device. However, on my device, triple-clicking will cause the device to send a NIF, which the binding treats as a wakeup. You can verify by tailing the log file.

If this works for you, and you’re able to get the device fully discovered, double check the wake up interval. Mine was set to a very large number (several days). I had to set it back to 3600 seconds.

@mhilbush

Mark, thank you so much! You suggestion completely solved the device discovery issue!

To those of you who may be considering this sensor and using the Aeotec’s Z-Stick Gen5 controller, this is what you have to do:

  1. Unplug the Z-Stick controller and put it into inclusion mode.
  2. Triple click the button on the device. The Z-Stick LED should turn solid blue for a few seconds to indicate the device has been recognized.
  3. Plug the controller back into the USB port and restart openHAB.
  4. Once openHAB is fully online, again triple click the button on the device. This will allow the binding to discover device. Note that the normal wake up method (press-and-hold the button for 2 seconds) does NOT enable the binding to discover the device at all.
  5. You should now be able to add this device as a thing.

Good luck to all!

Thanks !!!

1 Like

Glad to hear that worked. I’ll update the database entry to explain the triple-click.

Edit: Database has been updated.

1 Like