Downgrade from openHAB 2.5.3 back to version 2.5.1

Tags: #<Tag:0x00007f5c8f2576f8>

Hello to the forum!

I’m really annoyed from using v2.5.3. Especially the ZWave binding doesn’t seem to work as expected. There must be an error because I can’t edit ANY ZWave thing I added from the inbox. I always get the error message “Error 500: Internal Server error”.
This was different in v2.5.1 so I hope after downgrade the ZWave binding will work again as expected - it can*t get worse…

So does anyone can provide me a download link where I can download a Linux installation package (.deb)?

My system configuration is:
Raspberry Pi4
openhabian based on Buster

Regards

Ansgar

The ZWave binding in 2.5.3 is unchanged vs. 2.5.1 and absolutely fine, your problem is elsewhere.
That is, you don’t want to downgrade but you need to debug your system.
Try clearing the cache, eventually openhab-cli reset-ownership, check jsondb file permissions (writable?), eventually reinstall your current packages (apt-get install --reinstall openhab2 openhab2-addons openhab2-addons-legacy), check this thread and enable debugging if all of that didn’t help.

Can you try raising the log level of Jersey so it shows the stacktrace of the exception resulting in the 500 error?

log:set trace org.glassfish.jersey.server

hello wborn,

where shall I launch the log:set command and where will I find the log file?

Regards

Ansgar

You can enter it in The Console.

Then you can follow logging with the command: log:tail

And you can reset the logging back to the original level using:
log:set info org.glassfish.jersey.server

The stacktrace will probably also show up in the log files.
See Looking to the logs.

Hi wborn,

I set the loglevel of org.glassfish.jersey.server as you suggested, but there are no results shown neither in the openhab.log nor in the events.log when setting the filter to one of the following:

org.glassfish.jersey.server
glassfish
jersey
server

Is this an indication for that org.glassfish.jersey.server doesn’t cause the error “500: Internal Server Error”?

Maybe it does show when you do log:tail ? Perhaps additional logging configuration needs to be updated for it to be logged to files.

You should probably see something similar like the stacktrace in this comment.

Hi wborn,

I used the command log:tail -p org.glassfish.jersey.server and got output, but the shown errors belong to the enocean-binding.

Is there a way to save the output in a file to post the error messages here?

Regards

Ansgar

If you use PuTTY you should be able to copy/paste by selecting the text:

1 Like

Hello Markus,
I did all the steps you suggested, but the misbehavior is still there.
The strange thing is that the “Error 500: Internal Server Error” only occurs when trying to edit ZWave thing. All other things can be edited without error.
Unfortunately I can’t upload the screen videos I made to show my problem…
And in the log files openhab.log and events.log I can’t find any hint to the Error 500

Regards

Ansgar

Your zwave controller thing may be wrong (correct serial interface?) or your jsondb might even be corrupted. You can edit that manually (OH has to be down).

Hello Markus,
I think, the controller thing is ok because I can add thing, assign item to their channels and they are working.
But I have another problem which may be has an impact to this problem. Please see this link: ZWave: two serial controllers although only one is connected
Could this be solved by editing the jsondb? And where do I find that database?

Regards

Ansgar

Probably a good idea to start from scratch. jsondb is where OH stores what you click in PaperUI.
/var/lib/openhab2/jsondb/org.eclipse.smarthome.core.thing.Thing.json

Try just log:tail and then edit one of your Z-Wave Things to reproduce the error.

Have you tried deleting (not excluding) and rediscovering your Z-Wave Things? I agree that the issue is not with the binding itself, but somewhere else in your configuration.

Hello Markus,

I viewed the jsondb and there are only those ZWave things I added via PaperUI. No ghost things or duplicated things…

Hi Scott,

I did as you suggested. But there where no error entries in the log although I could reproduce the error…
And yes:
I deleted and rediscovered the ZWave things. And after adding the rediscovered things the behaviour was the same as before: No editing possible.
Even after hard resetting the ZWave-Dongle every thing I added wasn’t editable…

Have you tried opening the debugger in your browser (usually f12) to see if there is more information about the error?

How many ZWave devices do you have? Did you delete all the things, then add them all again and then try and edit one? Or did you delete all of them, add one back and try and edit it one at a time? It might be possible that there’s one thing that is causing the problem. If you add the things back one at a time and test at each step it would help determine which thing causes the error.

I appreciate that this can be a lot of work.

Do you have any ZWave things created in files or was everything created with the PaperUI?

2 Likes