Dragontech WD-100 dimmer not working properly with OpenHAB

Hi, I am new to openhab so please excuse my ignorance.

I have an openhab test installation on a raspberry Pi, using the z-wave binding. There are only two nodes on the network. Node 1 is a Z-Wave.Me ZME_UZB1 USB Stick and Node 3 is a Dragontech WD-100 in wall dimmer.

The WD-100 item is configured as follows:

Dimmer Dimmer1 “Test Dimmer [%d %%]” { zwave=“3:command=switch_multilevel” }

My default sitemap is a very simple one:

sitemap test label=“Main Menu”
Frame {
Text label=“Items Under Test” icon="house"
Frame {
Slider item=Dimmer1 label=“Dimmer1 [%d %%]” icon=“slider” switchSupport

So, when a click the up arrow once, the light turns on (100%). When I click the down arrow once, the light turns off (0%). So far so good.

However, when the light is off, and I click and hold the up arrow the dimmer increases to just the first level (5%) and no more. When the light is on (100%) and I click and hold the down arrow; however briefly, it always dims all the way down to 0%.

Can somebody please tell me what am I doing wrong?

P.D. I also have openzwave control panel in the pi. So, I stop openhab, and start openzwavecontrolpanel. The dimmer works as expected with openzwavecontrolpanel.

Ok, so I decided to try something else while I figured out why the dimmer wasn’t working like I thought it should.

I went into the Applestore and got myself the openhab app for my iPhone. I configured the url to my Pi openhab installation, saved it, and sure enough connected to my pi openhab from the iPhone app.

Guess what, I can increase and decrease the dimmer fine from the iPhone. It still doesn’t work from my PC using Chrome or Firefox. But it sure does work great from the iPhone app!

I tried using safari from the iPhone and it behaves exactly the same as it does from the PC running Chrome or Firefox. Something is broken with the web interface.

Anyway, many thanks to all the developers and the all the community for this great software Openhab.

Found this on Github,

Possible Classic UI Dimmer / Slider Bug #2900

This is the cause of the problem. I’m sure it will be fixed soon.