Drayton Wiser Thermostat Binding


(Sajid) #141

First of all, thanks again for your hard work!!

What do you mean when you say:
“I’d quite like to add schedules as it means if openHAB breaks, my heating can still work as normal (i.e. in auto mode).”

My heating still works if openHAB is down, as I am using it merely for monitoring. at some point I may manage it from openHAB, but still if you configure it this config data will be stored in the devices?

If opentherm is wired from boiler to WiserHub, can we see anything about the boiler status, ie. pump speed, flow, efficiency?

Thanks!


(Andrew Schofield) #142

I mean, I’d like to be able to use openHAB to automate the hub schedules (and letting the hub determine when to turn setpoints on and off etc), rather than the full blown solution of letting openHAB do absolutely everything, which requires the rooms to be in manual mode, with openHAB changing the set points itself. In the former scenario, if openHAB breaks for some reason, I know that the hub is still going to keep to a reasonable schedule, whereas in the latter scenario I could end up with everything stuck in the off state.

As it stands, the binding is perfectly usable (I think) in the full openHAB automation sense in terms of features (other than the timeout bug).

What I ideally want to be able to do is have “scenes” whereby I can set a particular room/house schedule. I.e. if either of us in on annual leave we want the house heated during the day, if one of us is on a late shift, we want the house heated in the morning, if we have guests staying we want the spare room heated etc. All this could be automated from a calendar binding, where it just triggers the correct “scene” and sends the required schedule to the hub.

Sadly not based on the json dumps you’ve provided, and my poking of the android app source. There doesn’t appear to be any OpenTherm specific data there. I wonder if it’s something that drayton will open up in the future, the hub is presumably capable of reading the data from the OpenTherm module…


(Andrew Schofield) #143

I made a change before the weekend which seems to be more stable for me. I set up a raspberry pi on Friday evening and it’s still going strong, so it might be worth a try. Still getting timeout messages in the log, and I suspect it might be a thread safety issue, which I think I can fix.


(Sajid) #144

Thanks for this, I will install and test it soon, however I noticed that now I see another issue which is similar but different (I think), sometimes I have to restart the OS in order to recover the system. Basically I am able to ssh and navigate, but it stops graphing until I reboot it, restarting the openhab service doesn’t work always.

Hopefully we can find a way to have this up and running in a stable way.


(Andrew Schofield) #145

Interesting, I was about to post the same thing. It looks like my “fix” has just allowed a working system to last a bit longer, mine died overnight last night and stopped updating the charts as well. I tried rebooting, but that didn’t appear to have worked this morning, but I’ll check again tonight.


(Sajid) #146

At least I am not alone :stuck_out_tongue:


(Rob Pope) #147

I’m just reading the manual to see what I need to do to bleed a valve and found this. Window detection is operational and just turns off the valve for ten minutes.

image


(ultraviolet) #148

Well spotted. My app updated on 14th Feb so this must have been added then. Still in beta?


(ultraviolet) #149

With the new IFTTT away mode I cant see any way to change the away temperature - it just goes to 16C. Have I missed something?

Another grumble. If the internet or cloud is down I can’t connect to the hub via the app. This seems contradictory to the FAQs on the Wiser website. Has anyone else found this to be the case? Openhab connects ok of course!


(Andrew Schofield) #150

The android app doesn’t appear to have been updated with open window detection yet, although the endpoint is already exposed via the API so it shouldn’t be hard to add it even though I won’t be able check that it’s working.

I’ve been out of the loop recently due to family circumstances, so haven’t made any progress on fixing the weird timeout problems, and I don’t actually know what state my Pi as got itself into.

@ultraviolet you’re right, the website says it should work without internet, and I think it has for me on the odd occasion that my router decides to boot everyone off. When you start the app it seems to fire requests off to the known local IP of the hub, and then to the cloud, so it should normally be able to connect directly to the hub. The android app is still a bit shoddy though and will regularly take ages to to load the room list and/or find the heat hub. I have no idea what it is doing when it is shows these messages on screen.


(Sajid) #151

@ultraviolet I did ask about this to the wiser support team and they said that it should work without internet access, actually they had a cloud outage just the day after I bought my system and I had a call with them and they told me that it should work without internet access, but because of the nature of the outage it was not working at that time.

In my opinion that was a lie, however I didn’t want to argue with them but it is quite awful that without internet access this doesn’t work properly.


(Sajid) #152

Hey Andrew, hopefully your family circumstances were nothing major, but wish you good luck with it.

Take care!


(Barry Balcanquall) #153

I was affected by the recent outage of the wiser cloud. I contacted support and they walked me through connecting the app directly to the hub. I think I was lucky and got the right support guy as how to do this is currently undocumented.
Basically it involved going through the setup procedure and selecting the local hub instead of the cloud.
I now have an spare phone with with the app configured to connect locally. Just in case there are future outages.


(Andrew Schofield) #154

Hey guys,

I’ve just had another go at trying to fix the timeout issue, which I’m now testing locally on my Pi. I haven’t pushed the code to github yet as it may not even work. I’m going to give it a few days to see what happens and report back.


(Paul Smith) #155

Apologies if I am hijacking a thread…I have wiser system with 3 TRV’s andca range extender, and have been looking for some way to trend what the system is doing…I came across openhab and the work you guys were doing. I followed the instructions, got the secret, installed the addin and discovered all my devices … all in half an hour! BUT… it does not discover any of the TRVs…do I really have to take each valve off and find the sticker with the serial number in it? Have I missed something? Is there any debug output I can look at? Can I test anything for any of you guys? Windows 10. Thanks, Paul


(Rob Pope) #156

Did you find the secret using something like Postman or SoapUI? If so browse to http//IP_ADDRESS/data/domain/ and you can find the TRV serial codes from there. I’m surprised they’re not found in paper ui though


(Paul Smith) #157

Wow. Super Quick Reply!
Just used a browser to browse to http://192.168.8.1/secret/ and boom! There it was -easy!

Will try what you suggest Rob . Thanks again.


(Andrew Schofield) #159

Paper UI should auto-discover the heat hub, which just needs you to fill in the SECRET in it’s config page. After that you should be able to run device discovery from the inbox and it should then find all the devices attached to the hub.
You shouldn’t need to plug in the serial numbers manually unless you are configuring openhab using .things files


(Paul Smith) #160

Hi guys;
Hub was discovered, and I plugged in the secret bit, then it discovered everything else except the iTRV’s. I took Rob’s advise and got the config from the HeatHub and manually added all the TRV’s. It seemed to add them all, but now they all appear as items in the “Control” tab, but either with all values as NaN or as 0.

In Configuration View they all show up as present and “online”, but in “Control” view, they show a device not connected.

I’m going to bed now, but will invest more time in this tomorrow. Thanks for the help so far guys. Much appreciated.


(Andrew Schofield) #161

If you wouldn’t mind posting your /data/domain/ that might be helpful. I’m not sure why discovery wouldn’t be able to find them if you can find the serial numbers yourself.