Dresden Elektronik deCONZ Binding stuck in initializing


I need some help because I’ve some trouble getting my system working. I’ve just migrated from Domoticz to openHAB to get better support for my devices.

During the migration I’ve had a lot of trouble getting Deconz working (CONBEE II). Deconz is running on the same device as openHAB.
All light and plug are working with the HUE binding (no issues here).

The problem is with the Dresden Elektronik deCONZ Binding.

  • Added the binding (using addons tab)
  • Go to configuration/things
  • Add thing --> Dresden Elektronik deCONZ Binding
  • Nothing found
  • Add manualy --> deCONZ A running deCONZ software instance
  • Fill host adress (same as used for openHAB (192…)
  • continue

deCONZ is added to things but keeps status “initializing”

Please could somesome help me with this (I’ve been busy for hours without succes)?

  • Platform information:
    • Hardware: Raspberry PI 4
    • OS: Raspbian Buster Headless
    • Java Runtime Environment: java 8
    • openHAB version: openHAB 2.5.2
  • Sensors:
    Temp/hum. sensors Aqara
    Light sensor Aqara
    Door sensor Aqara
    Motion sensor Tradfri

What does openhab.log tell you ?

For your lights and plugs you’ll need the HUE binding.
deCONZ also acts as a HUE bridge. This binding is meant to be used together with the HUE binding which makes the lights and plugs available
Install this binding Hue Binding and fill in you host address (or localhost) and you can use your lights.

I need to read the openingpost better :grimacing:

No reference to the binding or to deconz
Only all the ontehr actions I’ve been doing and status updates of the rolerblinds

Lights work with hue binding. Lights are no issue

I’m sorry, i’ve overlooked that you are using the HUE binding for you lights.
But what is the problem? In your opening post you don’t mention any sensors. If you haven’t got any, you don’t need the binding.

Sorry forgot to add this info.

I’ve got some
temp/hum. sensors Aqara
Light sensor Aqara
doorsensor Aqara
Motion sensor Tradfri

So to get my complete setup working I will need this binding

What port is deconz running on?

Also what openHAB version?

Did you use the api key the same as the one for hue emulation?

Deconz is running on port 80

openHAB 2.5.2 @port 8080

Initialy I used the same API key, when it didn’t work i made a new one.

  • removed API key (left empty)
  • Deconz software activated thrid party

So is it working ?

No this was not the solution to get it working :frowning:

I use files to configure my deconz setup. Have you considered a things file?

Also, did you see any errors in the openhab log file?

I didn’t because I didn’t know there was another way since I’ve just started in openHAB.

There where no error messages in the openhab log file regarding the deconz binding

Thank you all for the support.

I’ve solved the issue by reinstalling everything. I formatted my card and did a full reinstal. I’ve done the same as before but now with succes.
Think it was somekind of glitch :frowning:

Everything works fine for now! :smiley:


after my apt-get upgrade today I was suffering from the same issue (Phoscon-GW thing stuck in “initializing”). OH 3.3.0 on a Raspberry Pi with RaspBee II.

I solved the issue with less effort and I’m posting it here hoping it can help someone who is also suffering from this and stumbles upon this thread.

First: all devices were available and visible in the deCONZ GUI. So I thought it must be a binding issue…

These 4 steps solved it for me:

1.) remove the deconz binding
2.) remove the Phoscon-GW thing
3.) reinstall the deconz binding
4.) recreate the Phoscon-GW thing from the inbox (don’t forget to create a new API key).

All items are working again.