DS18B20 with Tasmota on ESP-01S

Hello I´ve a working ESP01 with Tasmota and a connected DS18B20. Tasmota is showing the temperature.

How is the correct way to connect it to Openhab, so I could see the temperature in the panel?

I have a DHT22 connected to a Tasmota device. I use MQTT to communicate between Tasmota and openHAB. Here’s my setup:

Thanks, but when I´m using your Thing code, it says:

missing EOF at ‘Type’

Probably best to continue discussion over on that thread.

However, I’ve just re-factored that page (as in, in the last half-hour), so you may want to completely re-do the copy/pasting!

And just to check: what version of openHAB are you running?

Thank you it´s working now

1 Like

Great! Could you post your Things file below? I’m interested in what your transformationPattern is for this sensor…!

Thing mqtt:topic:tasmota_009027 “Switch Porch Light” (mqtt:broker:MosquittoMqttBroker) {

	Type number : temperature "Temperature" [ 


1 Like


after a reboot of the rasp with openhab, the thermometer sensor show NULL in panel and - C at the basic UI.

Do I have to activate it again?


You will need to wait up to 5 minutes until the next tele message arrives…

I don´t know whats wrong.

Only thing - I install a tasmota wemeo d1 with 4 Relais

temperature isn´t show anylonger :frowning:

So you have added a second ESP device via MQTT? I presume they have different Client and Topic settings within the Tasmota MQTT parameters? What does your new Things file look like?

Install MQTT Explorer and use it to see whether your MQTT system is working in the first place. Then move back to openHAB.

1 Like

Thanks for help - looking to the MQTT Editor, everything looks fine. Tasmota 009027 is sending the Temp information and Tasmota D60060shows the actions at the relais Power1 to Power 4

I´m looked in the Terminal and get this warning:

2020-09-28 11:08:11.745 [WARN ] [ab.binding.mqtt.generic.ChannelState] - Command ‘{“Time”:“2020-09-28T10:08:11”,“Uptime”:“0T11:35:16”,“UptimeSec”:41716,“Heap”:27,“SleepMode”:“Dynamic”,“Sleep”:50,“LoadAvg”:19,“MqttCount”:1,“POWER”:“OFF”,“Wifi”:{“AP”:1,“SSId”:“Bmore Strategy”,“BSSId”:“7C:FF:4D:77:F8:D2”,“Channel”:11,“RSSI”:70,“Signal”:-65,“LinkCount”:1,“Downtime”:“0T00:00:09”}}’ not supported by type ‘OnOffValue’: No enum constant org.eclipse.smarthome.core.library.types.OnOffType.{“Time”:“2020-09-28T10:08:11”,“Uptime”:“0T11:35:16”,“UptimeSec”:41716,“Heap”:27,“SleepMode”:“Dynamic”,“Sleep”:50,“LoadAvg”:19,“MqttCount”:1,“POWER”:“OFF”,“Wifi”:{“AP”:1,“SSId”:“Bmore Strategy”,“BSSId”:“7C:FF:4D:77:F8:D2”,“Channel”:11,“RSSI”:70,“Signal”:-65,“LinkCount”:1,“Downtime”:“0T00:00:09”}}

The WARN comes from a switch-type channel most likely. The channel settings are looking at some MQTT message that it cannot process correctly.

Perhaps if you share that we can match it up with your channel config.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.