DSCAlarmBinding with EnvisaLink 4

Hi Community,

I’ve recently setup OH 1.8.0 on an rPI2 using the raspbian apt packaged distribution. I had hoped to connect this to my DSC 5010 alarm using the Envisalink module. I’ve got the EnvisaLink 4 module and now see that the references in the binding documentation refer to the model EnvisaLink 3 (hadn’t seen that before ordering the EL).

Is the binding compatible with the 4? I’m guessing not - but just wanted to confirm with the community.


1. Configuration
In /etc/openhab/configurations/openhab.cfg, I’ve included the disc alarm configuration parameters


(These haven’t been changed from the defaults on the EL4 and I’ve confirmed these work via the HTTP web interface to the EL 4).

2. Items
A simple, single binding to zone 5 to see if it can read a contact.

Contact ZONE5_GENERAL_STATUS "PIRm5 [%s]" (gAlarm) {dscalarm="zone:1:5:zone_general_status"}

3. Log-file
In the log-file, there’s a series of ‘Connection Refused’ errors.

19:01:06.341 [DEBUG] [.dscalarm.internal.model.Panel:51   ] - refreshItem(): Panel Item Name: PANEL_CONNECTION
19:01:06.358 [DEBUG] [.o.b.d.i.DSCAlarmActiveBinding:595  ] - closeConnection(): TCP Connection Closed!
19:01:06.366 [ERROR] [.o.b.d.i.DSCAlarmActiveBinding:142  ] - execute(): Not Connected to the DSC Alarm!
19:01:06.374 [DEBUG] [.o.b.d.i.DSCAlarmActiveBinding:558  ] - reconnect(): API Reconnection!
19:01:06.398 [ERROR] [o.b.d.i.connector.TCPConnector:127  ] - open(): Socket Exception: 
    java.net.SocketException: Connection reset by peer
    	at java.net.PlainSocketImpl.socketConnect(Native Method) ~[na:1.7.0_40]
    	at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339) ~[na:1.7.0_40]
    	at org.openhab.core.service.AbstractActiveService$RefreshThread.run(AbstractActiveService.java:173) [org.openhab.core_1.8.0.jar:na]

4. Ports open on EL4 - Nmap scan of Envisalink
Having read the source for the DSC binding, I see a TCP connection is made on port 4025 to the EL module. On the EL4, nmap seems to indicate there isn’t a TCP port open on 4025.

> nmap 192.168.X.XX

Starting Nmap 6.47 ( http://nmap.org ) at 2016-01-30 18:57 UTC
Nmap scan report for 192.168.X.XX
Host is up (0.00084s latency).
Not shown: 998 closed ports
80/tcp   open  http
8080/tcp open  http-proxy
Nmap done: 1 IP address (1 host up) scanned in 34.51 seconds

Since there’s no TCP port open that the binding’s expecting - does this mean it’s a dead-end with the EL4 - or - is there something I’m missing here?

Any advice / guidance appreciated.

Several things you may want to check:

Make sure there isn’t another device connecting to the Envisalink. The Envisalink will only allow one connection to it and drop all other devices that try to connect after that.

Be sure that the Envisalink is setup for the DSC alarm and not the Honywell Vista alarm.

Are you sure you have the correct IP address? Port 4025 should be open.


Thanks for the advice. Sorry for the delayed reply, another corrupt SD card forced a rebuild (note to self, don’t use the overclocking options in raspiconfig).

After reviewing your note, restarting both EnvisaLink and rPI several times, I ended up leaving it. 5-10 minutes later, the binding sprang into life. No changes to config.

I can only guess that while there was no active tcp between the rPI and the EL4, the EL4 doesn’t immediately release port 4025 for connection. After a timeout, the Binding was able to connect and now has been running without issue.

Thanks for the binding. It’s now the linchpin of my home automation and monitoring hub.


I ran into connection problems with the same setup OpenHAB 2 and Envisalink 4.

I checked the local envisalink web interface and found that TPI connection status is offline.
I checked the documentation for Envisalink TPI and found that before Envisalink 4 password can only be 6 characters long. With EVL 4 it can only be 10 characters long. I updated to a new random password of the right size and OH2 recognize it right away.

I’m using Envisalink 3 and I have a binding issue. Currently, the main utility of my Envisalink is to get an IP supervision of my DSC pannel instead of a phone supervision (no more phone line at home and replaced by an IP device). Following Stephens comment about only one connection allowed on the Envisalink: Should I understand it will not be possible at all to get a working binding to Envisalink? Is there any other possibility to hook up my DSC pannel to OpenHab?

Does this IP device act as a TCP server for the Envisalink? If so the DSC Binding allows this kind of connection. In OH2 this is actually built in as a TCP Server Bridge (not tested). You might be able to communicate with openHAB this way if possible.

Not sure to understand your proposition. The IP device I’m talking about is a NetTalk unit replacing my regular phone service. There is no link between The NetTalk and the Envisalink. I was explaining I’m using the Envisalink to monitor my DSC panel with the service provide by EyezOn. So I think there is a continuous connection to the Envisalink.

Sorry to not be more precise, I’m newbie with openHab. I’m still trying to figure out how to use it. I use X10 technology since a while and my goal is to continue to use all my current hardware and succeed to complete my system with new functionalities. Triggering some event from the DSC pannel is very interesting so thanks to you if you could guide me with the use of the Envisalink.

Sorry for the misunderstanding. When I said there is only one connection to the Envisalink that was not including the monitoring service by EyezOn, which is a separate. There can only be one local connection to the Envisalink. And this is built into the Envisalink itself not the binding. So you will still be able to connect to the DSC Alarm with openHAB and use the monitoring service. Hope this helps.

:slight_smile: good news ! I now just need to find out why the things is offline. I configured it with the right IP address (I double check it to be sure and I configured it in my router as static). I let the standard port 4025, I entered the right password. To be sure I was using the right password, I logged into the web interface of the envisalink. Because the web interface use port 8080, I also tried to configure the things in openHab with port 8080 without success. So now I have no more idea what else I can try. Thanks if you can give me more advice.

I got it! Password must be 6 digits on the Envisalink 3. My password was 8 digits long. This password was correct to connect to the web interface but not for the third party interface (TPI). Thanks for your time Russel.

Glad you got it working, Martin!

Hello, I just installed the bindings for my EVL-4 and I had a problem password too. But here’s the thing. My first password was 8 character long. When looking at the log file, the bindings throws an error saying it must be 4 to 6 character long. Ok, but here on the community, it is said that EVL-4 require 10 password long. So I set a new 10 char password, still the same error. I set it back to 6 and not it work. While it’s good to put something in the bindings to prevent bad password, maybe something should check which EVL and throw a warning instead of an error because with mine, it work with any character long when using TPI manually.

Hello @Nodiaque,

You are right the binding is checking for password length. The binding was originally setup for the EVL-2 which only required a 4 to 6 password length. I think the solution would be to remove the code that checks for password length altogether, and just rely on Envisalink replies to reveal any password errors. I will look into it as soon as I can.



Hi @rsstephens ,

Apologies for the necromancy, but has this feature ever materialized? Should I be aware of any “gotchas” if I try to use the official binding to take control of an EnvisaLink 4 via OpenHAB?


Yes this has been done. Here is the link to the pull request:


1 Like