Dual nano switch - not picking up manual switch triggers

Having some issues with different ZW132 - Dual Nano switches. I have two of these switches however one is by Aeotec and one is by the originating manufacturer Fantem. The problem and difference between these two switches is as follows:

FT132-B - original Fantem product purchased to operate our ensuite fan, it switches fan off after 10 minutes using a rule. A rule detects when the switch is turned on / off and works perfectly by ensuring the fan continues to operate after having a shower.

ZW132-B - Aeotec product purchased recently to operate our separate main bathroom fan in similar fashion, as the Fantem product can no longer be sourced. The rule was copied and modified to work accordingly however there seems to be a problem with the binding for this as it isn’t picking up change in status from the switches directly, although the settings are identical in the configuration. The switch can be controlled from the controller so it seems like its one-way transmission.

When placing OpenHab2 into debug mode, and the switch is manually triggered, I am getting a whole lot of lines appear in the debug file which would indicate that it knows something is happening. However I don’t have enough knowledge to decipher this but one would assume that it is communicating based on this.

There is a difference I have noticed when adding these devices into my items file, that the channel name is slightly different:

FT132-B - working and reporting from switch "switch_binaryX"
Switch EnsuiteFan “Ensuite Fan” (gEnsuite) [ “Switchable” ] { channel=“zwave:device:512:node11:switch_binary1” }

ZW132-B - not reporting / updating from switch "basic_switch_binaryX"
Switch BathroomLight “Bathroom Light” (gBathroom) [ “Switchable” ] { channel=“zwave:device:512:node15:basic_switch_binary1” }

Switch BathroomFan “Bathroom Fan” (gBathroom) [ “Switchable” ] { channel=“zwave:device:512:node15:basic_switch_binary2” }

i.e. difference is ZW is now using the prefix “basic” - not sure if this is having an impact on identifying individual switch.

If I change my items file to represent the dual switch itself (so both switches on the device) by using “switch_binary” without any numbers, and turn both switches manually ON, the changes get picked up by OH and rule gets processed etc. However the problem seems to be identifying individual switches on this device.

As an additional test, when I try to unlink the channel from the ZW132 device by clicking on the blue checkbox in PaperUI, I get an error 404 on either Switch 1 or Switch 2 and it doesn’t unlink. When I do the same for the FT132 device it unlinks and the blue circle becomes unchecked.

The difference between these devices is the FT132 is on v1.1 firmware, and the newer device ZW132 is on v2.2. In theory the older is working so it appears.

Let me know if you require any further information

At least for starter I can see that someone has swapped the channels over to link to the basic command class which is wrong. I’ve moved these back to the binary switch and will update the database over the weekend. Let’s see if that helps.

Thanks Chris. I’ll stop pulling my hair out and wait for the update. Cheers :slightly_smiling_face:

After the update and after completely removing and re-adding the device, it seems to have renamed the channel to switch_binary1 and switch_binary2 to fall in line with my other dual nano switch. However it still isn’t picking up manual changes from this actual switch. Other information is being updated such as wattage, volts etc. when the switch is triggered.

Once again as a test, getting an error 404 when attempting to unlink channel switch_binary1 and switch_binary2 still, so something isn’t right.

Hi Chris,

Have you had a chance to look at this problem ?

I don’t really have much I can look at. I’ve updated the database - all I can suggest is to check the association configuration, and possibly exclude and re-include the device to make sure these are set properly.

I completed another update today with intention to re-include as you mentioned. Updated to build 1413 and it seems to be picking up switch changes all of a sudden without needing to do anything further. Not sure what happened, but all good now :slight_smile:

Hey, I have 2 of the Zwave ZW132 and have never been able to get updates to the controller, other than the long term polling. I have tried just about every combination of settings I can think of.

Can you tell me what you updated to build 1413 and how you did it?

I am literally having my switch do the same thing, turning off bathroom fan after a set time.

Hi All

Ive got a ZW132 with the exact same issue. It wont report manual switch changes, other ZW devices such as the single switch report just fine.

Has anyone solved this issue?


Logged in just to say that a firmware update fixed mine. Contact Aeotec to get it.

1 Like