Dummy switch visible to paperUI and OH Cloud

I am looking to monitor when my wife is going to bed or getting up. My intention is to use IFTT on her phone and control these states through knowing when the phone is charging/discharging. Investigating the IFTT app shows that I can make visible certain items in the OH cloud service through the paper UI.

What I think I need to do is create a dummy switch that her phone can control, then when this switch is changed have OH rules that carry out the tasks.

I have tried creating a dummy trigger in the paperUI and despite being visible in Items it was not visible to the config of OH cloud. I have also tried adding a dummy switch using a new sitemap which was completely identical to the demo sitemap. This was also not visible to the OH cloud service config.

She is a darling, gets up early for her work, then wakes me up later when I need to get up (heavy sleeper)! Just right now she uses the damned light switches to turn the wifiLEDs off!

It won’t be visible until the Item receives and update or command of some sort. Did you exercise the dummy Item after adding it to the config?

And THAT is why I refuse to use smart bulbs. :slight_smile:


OK I just tried that, it is now shown but my other items have disappeared in PaperUI!

Did you inadvertantly set the Simple Mode flag?

What exactly did you do. And what surgically do to mean your items disappeared?

I have been using PaperUI to find/add/link Things to Items, and creating rules in etc/openhab2/rules/. I created a dummy switch using a sitemap file and after manual reboot of the pi the Things in PaperUI (but not the Items) disappeared.

In PaperUI I readded the things, but did not link any items. This made some rules work again.

Possible I should not mix the PaperUI and the Sitemaps, but I still do not understand how to add devices using the sitemap files.

I just checked and the simple flag is still disabled.

The error I get is;

2017-02-15 23:27:55.203 [WARN ] [ome.core.thing.internal.ThingManager] - Cannot delegate update ‘ON’ for item ‘ZWaveNode2FGMS001MotionSensor_MotionAlarm’ to handler for channel ‘zwave:device:37064aa9:node2:alarm_motion’, because no thing with the UID ‘zwave:device:37064aa9:node2’ could be found.

this make sense, how do I fix it?


In order to add items, you do not use sitemap files!
For manual adding of items, you should us the .items files!
.sitemap files only render the EXISTING items (declared in paperUI (automatically through the Configuration/System/Item Linking/Simple Mode Switch), or in .items files).

What you are encountering is a Thing Discovery problem.
I assume, but may be wrong in my assumption, that the possible causes of your problem are related to the lost state of a zwave device in the zwave controller.
LATER EDIT: no state issue with the zwave controller!

Best regards,


Yeah I think adding them back into PaperUI they have been assigned a different ID (37064aa9: old, 86c3bfe2: new). Is there any way to edit this for the PaperUI items? It doesn;t seem like it is supported for UI to modify this ID.

Possible to fix this I need to remove them in PaperUI and add them again with a different name, then update the rules accordingly.

Yes indeed, if you deleted the Thing. You still can rediscover the things and add them with your own chosen thing id’s. Do not just click, click, click, have a little patience! You have the options in PaperUI of adding/modifying the Thing Name and the Thing ID (the one that you are troubled about)! Feel free to set your own variables.

I didn’t delete anything, the Things removed themselves from PaperUI against my will. It looks like that ID is associated with the Zstick I am using. I have renamed the ID and hopefully things will work.