Easy timebased rule dosnt work

  • Platform information:
    • Hardware: Synology DS723+
    • openHAB version:4.0.4
  • Issue of the topic: an easy rule:" At Time X switch off the Light" dosnt work automaticaly. if i press on run now button, the light turns off.
  • Please post configurations (if applicable):
configuration: {}
triggers:
  - id: "1"
    configuration:
      time: 17:05
    type: timer.TimeOfDayTrigger
conditions: []
actions:
  - inputs: {}
    id: "2"
    configuration:
      itemName: Decke_OnOff_Only
      command: OFF
    type: core.ItemCommandAction

i made the setup of the rule witch the UI as an When → Time Event → “at a fixed time of a day”-> and set the time, etc.

i dont know why this easy rule dosnt work…

The rule configuration appears to be correct. So the most likely issue is that your system is not operating on the correct time. I don’t know about the synology installations, but there are several different places where OH may be getting the incorrect local time zone information so you have to try and see if the server time is correct.

Look at the lines in either of your log files to see if the server time matches the actual time.

Thank you, this is possible. i try to find out where i can find the logs or the systemtime in docker.

PS: OK Thanks that was the problem. For others who search for the same problem on Synology NAS.

Go to the Containermanager and stop your openHAB Container.
(my version is german therfore i try to translate)
Go to the Settings and under Environment add the Line:

“EXTRA_JAVA_OPTS” and on the right side" -Duser.timezone=Europe/Berlin" if you are in Germany

Restart and openHAB should have the correct systemtime