Ebus bindung with new ebus 3.0 adapter

I would like to use the new ebus 3.0 adpater eBUS Adapter 3.0
I have a Vaillant calormatic 630, a Wolf CWL 300 and openhab on a raspberry PI 4.
Has anyone tried the new adapter and does it work with the ebus bindung?
Which adapter version (USB, Ethernet, WiFI…) works best with the raspberry?

Hi Reinhard,
I use the eBus adapeter 3.0 with a RasPi4. To avoid wiring I have put it directly on the RasPi using the GPIO connection option. Works without problems with the ebus binding. Only the jumpers have to be set correctly.
Best, Thomas

Great! Do you have a case where the raspi with the ebus adapter fits?

Yes, but it is unusual. I use a ‚Hutschienen-Gehäuse‘ as my RasPi it sits in my electrical distribution cabinet (Verteilerschrank). Due to the Hutschienen form factor there is ample space inside.

I just heard that the ebus binding is not working with openhab 3. Is that correct?

No this is not correct. I do have the following configuration working flawlessly:

  • Raspberry Pi 4 Model B, 4Gb RAM
  • openHABian 3.0.1 - Release Build
  • org.openhab.binding.ebus-3.0.11.kar
  • eBus 3.0 Adapter

Some hints for those wanting to use this adapter: it is a project from the FHEM community, just search for “eBUS Adapter 3.0”
I use it in the GPIO configuration. It works without problems. Here are some hints you have to follow to avoid problems:

  • take care to put it correctly into the socket (flush with the bottom pins)
  • set the jumpers correctly (look at the installation guide at adapter.ebusd.eu)
  • deactive the serial login shell and activate the serial port hardware. In the documentation they use “raspi-config”. On openhabian use “sudo openhabian-config” and change entries 30 and 35 appropriately (login shell: no, serial port HW enabled: yes)
  • follow all the other steps, though
  • important: set jumper J12 (jumper on the right lower edge of the PCB) to “standard protocol”
  • after everything has been installed incl. the binding create an eBUS bridge and select as serial port “/dev/ttyAMA0”

Have fun!

1 Like

You are right! It works with OH 3.
I connected with Wifi using the following instructions: GitHub - john30/ebusd-esp: Firmware for ESP8266 allowing eBUS communication for ebusd (https://github.com/john30/ebusd)
The ebus bridge is now online but I don’t receive any telegrams.
I guess I have do change further settings e.g. the eBUS Master Address, but I don’t know where to start. Master Address “1” doesn’t work.
Although I don’t know how to connect the bus correctly I don’t find a + an - on the ebus board. I tried both possibilities without any difference.
Any hints where to start or where I can find information?

Remote debugging is always difficult if hardware is involved. I would try the following steps:

  • Hardware: Is the adapter properly powered and does it receive eBus signals? To check this the adapter has a couple of LEDs, e.g. yellow=power, green=eBus data received. Just look at Willkommen zum eBUS Adapter 3!. Looking at the circuit diagram, the eBus inputs are fed into a rectifier diode circuitry. Means: The eBus wiring works both ways. I don’t think that you have to tinker with the eBus addresses. If the green LED is blinking I would guess that the adapter properly receives data.
  • Wifi: Is Wifi properly enabled? The blue LED gives some hints (see LED meaning above)
  • Communication: Does the Raspberry Pi receive data? From here on I cannot help anymore I don’t have experience with the Wifi mode. I would try to get support from the FHEM community (eBUS Adapter 3.0)
  • eBUS Binding: Does the eBUS openHAB binding is set correctly? There, I would continue the discussion in the respective forum ([eBUS 2.0,3.0] Binding - Release 2.50.11 & 3.0.11)

Hope this gives you at least some debugging direction.

Thank you for the hints.
The green light is constantly flashing, so data is received.
The Wifi is working fine. I can address the adapter by its IP.
The result is:

eBUS adapter 3

Build: 20201122
ebusd device string: enh:192.168.8.xxx:9999
WiFi signal: 62% (-69dBm)
Chip ID: 00d17d9a
Hostname: ebus-d17d9a
Up time: 149
Free heap: 34840
ebusd connected: no
eBUS signal: no signal

The eBUS receives no signal although the green light is blinking. Is there an explanation for this?