Echo Control binding cycles on first login


I would like to get the Echo Control binding installed. But I do not even seem to get past the very first step.

I am running Openhab 2.5.8-1 and first tried with the binding via PaperUI.

After install I create an account thing and call the link for this acount offered via the “/amazonechocontrol/” link.

It starts the Amazon account registration process and I get a text to my mobile asking for authorization.

Before I even have a chance of approving on my mobile the PC screen cycles back to the initial login page that now has no credentials anymore. This can go on forever.

I tried to approve faster :slightly_smiling_face: but obviously no success.

I changed to the 2.5.9 snapshot of the binding, but also no success.

Anybody has got a hint why I am stuck here?

1 Like

Same issue here… This doesn‘t happen when I directly go to I get the same login procedure but it remains waiting for confirming the login. Looks like a kind of refresh-issue within the binding…