Eclipse SmartHome Designer error in items File: missing EOF at [

dear all

Since upgrading Eclipse SmartHome Designer I get an error on the first line of the items file, i.e.

missing EOF at [

The first line of the items file looks like that (used for homekit binding):

Switch home “zuhause” [“Switchable”] {knx=“7/4/3”}

has anybody an idea what the problem could be here?

Any help would be highly appreciated


Copy, clear und paste all lines.

Please note that the Designer has been deprecated is not part of the release anymore.

Now I use Visual Studio Code.

Thank you for that fast reply, but that does not help. Even when I have just the first line

Switch home “zuhause” [“Switchable”] {knx=“7/4/3”}

in items file i get the error

What is wrong here?

Try a other editor.
Is it a Windows or a Linux-file?

When I paste this into VS Code, the double quotation marks are incorrect.

They are:

Switch home “zuhause” [“Switchable”] {knx=“7/4/3”}

They should be:

Switch home "zuhause" ["Switchable"] {knx="7/4/3"}

Thank you a lot for your hints

the file sits on my raspberry, so I guess it is a linux-file. However editor is running in Windows

I tried to copy the “right” quotation marks in the editor, but the error still occurss. i guess it is a bug in Eclipse?

Thank you again for the help!

So I tried to switch the VS code. However, the nice thing with Eclipse was that i was immediately indicated when there was a syntax error. I don’t get it, how this feature works in VS code. Could anybody give me a hint to it?

Thank you a lot


The validation feature for VSCode is currently only working on the snapshot version.
I think it will be included in the 2.2 release, which has been announced for preparation some days ago.