Ecobee API change

Yes. I finally got a response after tweeting to their VP of Technology. :wink:

As soon as the test environment is ready, they’ll give me access.

Note that I’ll be posting updates on the main Ecobee binding forum thread.

Please tell me the change, if viable, will come to the latest stable 2.x line of openhab as well and not just 3.x

Only if you say pretty please. :wink: :laughing:

If any changes are required (which at the moment I don’t think there will be), I’ll make the change in 2.5.x and 3.0.

1 Like

Pretty please :slight_smile:

1 Like

Pretty please (still running v2.4) that you helped me out with many months ago.

Best, Jay

As soon as they get back to me with a test environment, I’ll verify what needs to change, if anything. It’s getting late. I pinged them again a couple days ago.

The plan is to change both 2.5.x and 3.0 (assuming a change is necessary). @jwiseman Are you running the 2.5.x version on 2.4?

I made a mistake stating 2.4, I’m still running the 1.x version of Ecobee. I understand I’ll need to upgrade to 2.5 when the API is fixed and change some items to get it working again.

openhab> list -s | grep ecobee
289 │ Active │ 80 │ 1.13.0 │ org.openhab.action.ecobee
290 │ Active │ 80 │ 1.13.0 │ org.openhab.binding.ecobee

Best, Jay

I’m running 3.0.0-SNAPSHOT - Build #2039 which has the new api changes and I’m getting errors when trying to enter the pin in My Apps on the ecobee website. They pin is in the format ‘XXXX-YYYY’:


Thats the correct format for the new PINs. I have no idea Ecobee would be throwing an error.

The interface for entering the PIN has changed. Are you seeing that new interface?

No I still see the old interface. I’ll email ecobee support

After you enter the XXXX-XXXX PIN, you should see this.

Followed by this.

Followed by this.

I don’t see anything like that. BTW, I have one of the original smart thermostats. This is the My Apps panel:

Then I get this when I enter the pin and press the “Install App” button:

Hmm. What app is that that you’re using?

Have you tried doing it from the Ecobee web portal, or does that not work for that model thermostat?

I go to, and sign in the upper hand corner. Once I login it goes to, which appears is what I get with the original smart thermostat. Once I log in I can go to and get the new portal. I also found a way to get to if from the old portal:

Select Add Thermostat to open the thermostat panel and select ecobee 3:

Then select Proceed:

This switches to the new portal, press X on the ADD THERMOSTAT panel, and then I get the new portal. If I log out and back in. I’m back to the old portal.

Using either approach, I was able to complete the steps in the documentation and got it to work again.

Glad you got it sorted. Thanks for figuring that out!

Me too, I’ve reached out to support. Don’t know why I don’t have the new portal, I have the new look with my android app.

Yeah, definitely should ask them. I’ll bet they forgot to update the PIN processing in the old portal.

I got upgraded to the new portal, anybody who is using the old web portal will need to be upgraded as well. If the portal is green instead of black, its the old portal. The only way to get the new portal is to add a newer device. The steps they will need to take are:

  • Go to, and click on “Chat with us” at the bottom of the page
  • Tell the support person that you are still on the old portal with a green background and need to be upgraded to the new portal to add apps
  • In the portal go to the “Add Thermostat” and pick “ecobee 3” (image is above if needed)
  • the portal will switch to a black background and will be asked to enter a 4 character registration code. The support person will provide you the 4 character code, enter it here
  • Fill out the info about your house, etc that appear on the following screens
  • Now you will be upgraded to the new portal, and will have a second device. You can remove the new device, if you don’t the support person will probably do it for you.

What do i need to do to get this working; using openhab 2.5.10
Ecobee was working this entire time; now in the log:

2020-12-30 14:27:27.539 [ERROR] [oauth2client.internal.OAuthConnector] - grant type refresh_token to URL failed with HTTP response code 404
2020-12-30 14:27:27.541 [INFO ] [inding.ecobee.internal.api.EcobeeApi] - API: Got exception trying to get access token from OAuth service

I’ve tried uninstalling the binding and clearing out the json and the files as per the other thread; upon startup and entering API, i still just get that in the log; no new key generates, etc. DO i need a new version of the binding? If so, how do i get this?