Ecobee API change

I go to, and sign in the upper hand corner. Once I login it goes to, which appears is what I get with the original smart thermostat. Once I log in I can go to and get the new portal. I also found a way to get to if from the old portal:

Select Add Thermostat to open the thermostat panel and select ecobee 3:

Then select Proceed:

This switches to the new portal, press X on the ADD THERMOSTAT panel, and then I get the new portal. If I log out and back in. I’m back to the old portal.

Using either approach, I was able to complete the steps in the documentation and got it to work again.

Glad you got it sorted. Thanks for figuring that out!

Me too, I’ve reached out to support. Don’t know why I don’t have the new portal, I have the new look with my android app.

Yeah, definitely should ask them. I’ll bet they forgot to update the PIN processing in the old portal.

I got upgraded to the new portal, anybody who is using the old web portal will need to be upgraded as well. If the portal is green instead of black, its the old portal. The only way to get the new portal is to add a newer device. The steps they will need to take are:

  • Go to, and click on “Chat with us” at the bottom of the page
  • Tell the support person that you are still on the old portal with a green background and need to be upgraded to the new portal to add apps
  • In the portal go to the “Add Thermostat” and pick “ecobee 3” (image is above if needed)
  • the portal will switch to a black background and will be asked to enter a 4 character registration code. The support person will provide you the 4 character code, enter it here
  • Fill out the info about your house, etc that appear on the following screens
  • Now you will be upgraded to the new portal, and will have a second device. You can remove the new device, if you don’t the support person will probably do it for you.

What do i need to do to get this working; using openhab 2.5.10
Ecobee was working this entire time; now in the log:

2020-12-30 14:27:27.539 [ERROR] [oauth2client.internal.OAuthConnector] - grant type refresh_token to URL failed with HTTP response code 404
2020-12-30 14:27:27.541 [INFO ] [inding.ecobee.internal.api.EcobeeApi] - API: Got exception trying to get access token from OAuth service

I’ve tried uninstalling the binding and clearing out the json and the files as per the other thread; upon startup and entering API, i still just get that in the log; no new key generates, etc. DO i need a new version of the binding? If so, how do i get this?


I’d suggest you try the following.

  • Uninstall the version of the Ecobee binding you’re currently running
  • Stop openHAB
  • Get and install the latest 2.5.x version of the Ecobee binding from here
  • Delete the openHAB app in the MyApps area of your Ecobee portal
  • Delete the JSON DB OAuth files in userdata/jsondb (primary and backup files)
  • Restart openHAB

Hopefully that will result in you having to reauthorize the binding with Ecobee

Thanks Mark; yeah tried all of that a few times; what i eventually had to do was delete the ecobee account in the things area of paper UI; then it regenerated the pin for me.