Ecobee: Error during Initial Command Bind

Hi,

I never get the prompt in the logfiles with the PIN to enter.

Here are the relevant openhab.cfg lines (x replacing * for this presentation)

xthe temperature scale to use when sending or receiving temperatures
xoptional, defaults to Fahrenheit (F)
ecobee:tempscale=F

xthe private API key issued be Ecobee to use the API (replace with your own)
ecobee:appkey=DuavoP3jWuot0ogp1Uf8iqBYA6OEt2Cx

xthe application scope used when authorizing the binding
xchoices are smartWrite,smartRead, or ems, or multiple (comma-separated, no spaces)
ecobee:scope=smartWrite

Here is the relevant ‘items’ line:
Number Temperature_FF_Fireplace “Temperature [%.1f °F]” { ecobee="<[319226960206#runtime.actualTemperature]" }

Any idea what would cause this?

-ken

Hi Ken,

Which version of the Ecobee binding are you using? If 1.7.0, then please upgrade due to later fixes. I personally recommend pulling a 1.8.0-SNAPHOT JAR from the addons.zip file here and replacing your current binding JAR with this one (don’t rename files, just remove old JAR and put new one in the same folder), so you are starting with what will appear in the nearly ready 1.8 release.

If the appkey in your original message above is real, please revoke it and create a new one, as this will serve two purposes:

  • avoid any situation where someone reading this could use your appkey instead of one they themselves registered
  • tells the binding that any saved tokens in openHAB should be ignored since they don’t match the new appkey. This should trigger a new PIN registration that appears in openhab.log, which you can then enter into your Ecobee portal under Apps.

Please let us know if this helps!

Thanks, John

I downloaded the zip file, extracted the ecobee 1.8 jar file, placed it in the addons directory and then removed the 1.7 ecobee jar file.

I did revoke the old appid and create a new appid and updated the openhab.cfg file and saved it.

I restarted. I did not get the prompt in the log file and I also did not did not get any entries this time in my ecobee log file.

Any ideas?

Some random ideas and questions:

  • Are you sure “319226960206” is really your thermostat’s ID?
  • Did you wait at least three minutes for the message to appear in your log?
  • Have you at any time previous edited your logback.xml file to change how logging is done?
  • If not, could you add
<logger name="org.openhab.binding.ecobee" level="TRACE"/>

below the line

<logger name="org.openhab" level="INFO"/>

and post parts of the log that might be useful (obscuring any private information that might have been logged)?

If none of that is fruitful and you are running on Linux/OSX, look to see if you have a directory called .userPrefs here:

sudo ls -al ~USER/.java/.userPrefs/

where USER is openhab if you installed from apt-get and didn’t change the user that runs the server, or pi if you are running the server as pi, etc. If you do, stop openHAB and delete the .userPrefs directory and contents

sudo rm -rf ~USER/.java/.userPrefs

and restart openHAB. Look to see if that directory is created again after the Ecobee binding starts, and wait at least 3 minutes while looking at the end of the openhab.log file.

Please let me know if any of this helps.

Well, I figured it out.

The zip file has two ecobee jar files. The first one I saw was the actions file which is what I copied/pasted to the add-ons directory and at that time I deleted the bindings file. Something triggered me to go back and look again and then I realized I needed to scroll down to see the ecobee bindings file which I copied/pasted into the add-ons directory. That fixed it. PIN code prompt, entered into the site and now it works.

Thank you so much for guiding me through this. I appreciate it.

HI!
I got the same kind of problem running OpenHAB 1.7 on Win 10 / JRE 8u66 and this thread helped me a lot.

Here is what I did:
I obtained latest 1.8 ecobee binding from cloudbees at https://openhab.ci.cloudbees.com/job/openHAB/
I created a new appid on ecobee web portal and updated the openhab.cfg
Lauched OpenHAB and finally got the Authentication PIN after a couple of minutes.

I am now an happy OpenHAB user with access to my ecobee tsat !

Many thanks for your support and coding of this great binding!

  • Denis
1 Like