Ecobee invalid_grant errors

I just started having this problem after a Windows 10 update. I’ve checked the registry key but it doesn’t exist anywhere… Everything was working before the update


I am using the ecobee binding on latest release of openhab2, yesterday for the first time in 3 years I got the error message about invalid_grant in the logs.

I run Openhabian on a Pi and I can’t find a way to delete the .userPrefs.
I tried everyting to get rid of this and get the authorization code again but I am stock.

Tried :
sudo -u openhab rm -rf ~openhab/.java/.userPrefs
sudo -u openhab rm -rf /var/lib/openhab2/.java/.userPrefs
I hava a directory .java in /var/lib/openhab2 but this directory is empty.
Tried to go manually to directory etc.

On SSH I am connecting to my instance with openhabian@openHABianPi

Where is this directory on Openhabian on my PI ?
Can you help me to find it?
Is there any way to get the code again without deleting this directory.

Thanks a lot !

I find it I am running on root for some GPIO settings on the pi.

sudo -u root rm -rf ~root/.java/.userPrefs fixed it.

1 Like

Thank you, I don’t know who can get this information over to the binding info page:

However after hitting this issue, it was definitely not clear that the folder was in the openhab user’s home directory, a folder that doesn’t show in the filesystem (I’m still using Ubuntu 16.04), or at least I was not experienced enough to know how to look for it.

A “request” is for these things to be indicated better in the logs (hey, go to this folder and delete stuff to reset) or for the binding to have a reset flag in the config so that I don’t need to be stuck trying to find where files are stored. Usually updates are the cause of problems for me, and thus I have no idea what happened, so I don’t have 100% confidence I’m even in the right folder (this is a case in point) resulting in the Homer Simpson spinning in circles on the floor getting nowhere.

To put it in context, I could have built a new VM and reinstalled faster than it took to find the folder to delete it, and get a new PIN. There’s a forehead hole in my desk (kidding of course).

Above all thanks, I would never have found the folder to delete without your description.