Ecobee thermostat invalid grant in windows 10


(Kimberly Fischer) #1

I have searched and searched and at a loss as to what i need to delete to get my ecobee thermostat working again. I am getting an invalid grant.

Error retrieving tokens: invalid_grant

I have recently switched from a pc server to a windows computer stick that was working fine. The ecobee just stopped working and i get this error. I know on linux i am to delete the java preferences but the documention just says that the java setttings are store in the windows registry.

Anyone have any more specific info on how to do this in windows 10.

Thanks a bunch

Kim.


(Angelos) #2

You didn’t search the forum… #1, #8, #9 How to ask a good question


(Kimberly Fischer) #3

This post was flagged by the community and is temporarily hidden.


(Angelos) #4

image

1st search result is the post that I linked even without underscore

same forum software, same full text search engine…
but don’t let me keep you here, go over there and swear at them…


(Kimberly Fischer) #5

Did all of that from the post. Uninstalled the ecobee bindings and actions. Deleted the java pref from the windows 10 registry. Deleted the app from my ecobee account online. Restarted openhab. Same issue. Restarted a few times…same issue.

2018-12-16 19:17:06.164 [ERROR] [inding.ecobee.internal.EcobeeBinding] - Error retrieving tokens: invalid_grant
2018-12-16 19:17:06.164 [WARN ] [inding.ecobee.internal.EcobeeBinding] - Periodic poll skipped for ‘DEFAULT_USER’.

At a loss…excuse my poor searching ability in the messages. I may be too dumb for this.