Ecolink PIR-ZWAVE2.5-ECO inclusion

Tags: #<Tag:0x00007f386bdc4bf0>

I would like to include the Ecolink pir motion sensor 2.5 but is not being detected by openhab2 also i’m using aeotec gen 5 zwave plus on ubuntu desktop 18.04. Does anyone know how to include this item in openhab2?

regards

Cristian

This would be a good starting point, especially the sections on inclusion and battery devices.

And this for the specifics of the device.
https://www.openhab.org/addons/bindings/zwave/thing.html?manufacturer=eco&file=ecolinkpirv25_0_0.html

I have this sensor (and previous generation) running fine with OH 2.3, 2.4 and aeotec g5. I did not do anything special to include sensor. Any logs? Steps you are using to pair sensor with controller ? Did you try battery reset for sensor?

the logs doesn’t show the attempt of inclusion of the ecolink pirzwave2.5-eco

please help

00:11:46.327 [DEBUG] [zwave.discovery.ZWaveDiscoveryService] - ZWave discovery: Stop zwave:serial_zstick:2e1173a3
00:11:46.327 [DEBUG] [ave.internal.protocol.ZWaveController] - ZWave inclusion process not running - nothing to do
00:11:46.328 [DEBUG] [zwave.discovery.ZWaveDiscoveryService] - ZWave discovery: Start zwave:serial_zstick:2e1173a3
00:11:46.328 [DEBUG] [ave.internal.protocol.ZWaveController] - ZWave controller start inclusion - mode 2
00:11:46.328 [DEBUG] [ave.internal.protocol.ZWaveController] - Event listener added.
00:11:46.329 [DEBUG] [nal.protocol.ZWaveInclusionController] - ZWave controller start inclusion
00:11:46.329 [DEBUG] [col.serialmessage.AddNodeMessageClass] - Setting controller into INCLUSION mode, highPower:true networkWide:true.
00:11:46.329 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - NODE 255: Added 2365 to queue - size 1
00:11:46.330 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 0 out at start. Holdoff false.
00:11:46.330 [DEBUG] [zwave.internal.protocol.SerialMessage] - Assembled message buffer = 01 05 00 4A C1 29 58
00:11:46.330 [DEBUG] [ding.zwave.handler.ZWaveSerialHandler] - NODE 255: Sending REQUEST Message = 01 05 00 4A C1 29 58
00:11:46.331 [DEBUG] [ding.zwave.handler.ZWaveSerialHandler] - Message SENT
00:11:46.331 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage started: TID 2365: [WAIT_REQUEST] priority=Controller, requiresResponse=true, callback: 41
00:11:46.332 [DEBUG] [ZWaveSerialHandler$ZWaveReceiveThread] - Receive Message = 06
00:11:46.332 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - processReceiveMessage input 0<>128 : Message: class=null[0], type=ACK[2], dest=255, callback=0, payload=
00:11:46.333 [DEBUG] [ZWaveSerialHandler$ZWaveReceiveThread] - Receive Message = 01 07 00 4A 29 01 00 00 9A
00:11:46.333 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Received msg (0): Message: class=null[0], type=ACK[2], dest=255, callback=0, payload=
00:11:46.333 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - lastTransaction TID 2365: [WAIT_REQUEST] priority=Controller, requiresResponse=true, callback: 41
00:11:46.333 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Received msg: ACK
00:11:46.333 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - ZWaveReceiveThread queue empty
00:11:46.333 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 1 out at start. Holdoff false.
00:11:46.334 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - processReceiveMessage input 0<>128 : Message: class=AddNodeToNetwork[74], type=Request[0], dest=1, callback=41, payload=29 01 00 00
00:11:46.334 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Received msg (0): Message: class=AddNodeToNetwork[74], type=Request[0], dest=1, callback=41, payload=29 01 00 00
00:11:46.334 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - lastTransaction TID 2365: [WAIT_REQUEST] priority=Controller, requiresResponse=true, callback: 41
00:11:46.334 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Checking outstanding transactions: 1
00:11:46.334 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Last transaction: TID 2365: [WAIT_REQUEST] priority=Controller, requiresResponse=true, callback: 41
00:11:46.335 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Checking TID 2365: (Callback 41)
00:11:46.335 [DEBUG] [l.serialmessage.ZWaveCommandProcessor] - Callback match!
00:11:46.335 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Correlated to TID 2365: callback 41
00:11:46.335 [DEBUG] [ave.internal.protocol.ZWaveController] - Incoming Message: Message: class=AddNodeToNetwork[74], type=Request[0], dest=1, callback=41, payload=29 01 00 00
00:11:46.335 [DEBUG] [col.serialmessage.AddNodeMessageClass] - Add Node: Learn ready.
00:11:46.335 [DEBUG] [nal.protocol.ZWaveInclusionController] - Inclusion event: Current state IncludeSent, new event IncludeStart
00:11:46.335 [DEBUG] [ve.internal.protocol.ZWaveTransaction] - TID 2365: Transaction COMPLETED
00:11:46.336 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - NODE 255: Response processed after 5ms
00:11:46.336 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - NODE 255: TID 2365: Transaction completed
00:11:46.336 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - NODE 255: notifyTransactionResponse TID:2365 DONE
00:11:46.337 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - ZWaveReceiveThread queue empty
00:11:46.337 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 0 out at start. Holdoff false.
00:11:48.334 [DEBUG] [zwave.discovery.ZWaveDiscoveryService] - NODE 2: Device discovery completed
00:11:48.336 [DEBUG] [zwave.discovery.ZWaveDiscoveryService] - NODE 2: Device discovery resolved to thingType zwave:fortrezz_fmi_00_000
00:11:48.340 [DEBUG] [zwave.discovery.ZWaveDiscoveryService] - NODE 3: Device discovery completed
00:11:48.340 [DEBUG] [zwave.discovery.ZWaveDiscoveryService] - NODE 3: Device discovery resolved to thingType zwave:ufairy_gr105_00_000
00:11:48.340 [DEBUG] [zwave.discovery.ZWaveDiscoveryService] - NODE 4: Device discovery completed
00:11:48.341 [DEBUG] [zwave.discovery.ZWaveDiscoveryService] - NODE 4: Device discovery resolved to thingType zwave:zipato_rgbwe27zw_00_000
00:12:16.328 [DEBUG] [zwave.discovery.ZWaveDiscoveryService] - ZWave discovery: Stop zwave:serial_zstick:2e1173a3
00:12:16.330 [DEBUG] [nal.protocol.ZWaveInclusionController] - ZWave controller stopping inclusion at IncludeStart
00:12:16.331 [DEBUG] [col.serialmessage.AddNodeMessageClass] - Ending INCLUSION mode.
00:12:16.332 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - NODE 255: Added 2366 to queue - size 1
00:12:16.333 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 0 out at start. Holdoff false.
00:12:16.334 [DEBUG] [zwave.internal.protocol.SerialMessage] - Assembled message buffer = 01 05 00 4A 05 2A 9F
00:12:16.334 [DEBUG] [ding.zwave.handler.ZWaveSerialHandler] - NODE 255: Sending REQUEST Message = 01 05 00 4A 05 2A 9F
00:12:16.334 [DEBUG] [ding.zwave.handler.ZWaveSerialHandler] - Message SENT
00:12:16.335 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage started: TID 2366: [WAIT_REQUEST] priority=Controller, requiresResponse=true, callback: 42
00:12:16.336 [DEBUG] [ZWaveSerialHandler$ZWaveReceiveThread] - Receive Message = 06
00:12:16.336 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - processReceiveMessage input 0<>128 : Message: class=null[0], type=ACK[2], dest=255, callback=0, payload=
00:12:16.337 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Received msg (0): Message: class=null[0], type=ACK[2], dest=255, callback=0, payload=
00:12:16.337 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - lastTransaction TID 2366: [WAIT_REQUEST] priority=Controller, requiresResponse=true, callback: 42
00:12:16.337 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Received msg: ACK
00:12:16.337 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - ZWaveReceiveThread queue empty
00:12:16.337 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 1 out at start. Holdoff false.
00:12:16.422 [DEBUG] [ZWaveSerialHandler$ZWaveReceiveThread] - Receive Message = 01 07 00 4A 2A 06 00 00 9E
00:12:16.424 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - processReceiveMessage input 0<>128 : Message: class=AddNodeToNetwork[74], type=Request[0], dest=6, callback=42, payload=2A 06 00 00
00:12:16.425 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Received msg (0): Message: class=AddNodeToNetwork[74], type=Request[0], dest=6, callback=42, payload=2A 06 00 00
00:12:16.427 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - lastTransaction TID 2366: [WAIT_REQUEST] priority=Controller, requiresResponse=true, callback: 42
00:12:16.428 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Checking outstanding transactions: 1
00:12:16.428 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Last transaction: TID 2366: [WAIT_REQUEST] priority=Controller, requiresResponse=true, callback: 42
00:12:16.429 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Checking TID 2366: (Callback 42)
00:12:16.430 [DEBUG] [l.serialmessage.ZWaveCommandProcessor] - Callback match!
00:12:16.431 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Correlated to TID 2366: callback 42
00:12:16.432 [DEBUG] [ave.internal.protocol.ZWaveController] - Incoming Message: Message: class=AddNodeToNetwork[74], type=Request[0], dest=6, callback=42, payload=2A 06 00 00
00:12:16.432 [DEBUG] [col.serialmessage.AddNodeMessageClass] - Add Node: Done.
00:12:16.433 [DEBUG] [nal.protocol.ZWaveInclusionController] - Inclusion event: Current state IncludeDone, new event IncludeDone
00:12:16.435 [DEBUG] [col.serialmessage.AddNodeMessageClass] - Ending INCLUSION mode.
00:12:16.436 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - NODE 255: Added 2367 to queue - size 1
00:12:16.437 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 1 out at start. Holdoff false.
00:12:16.438 [DEBUG] [nal.protocol.ZWaveInclusionController] - ZWave controller end exclusion
00:12:16.439 [DEBUG] [ave.internal.protocol.ZWaveController] - ZWaveController include done
00:12:16.441 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - TID 2366: Advanced to DONE
00:12:16.442 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - NODE 255: Response processed after 107ms
00:12:16.443 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - NODE 255: TID 2366: Transaction completed
00:12:16.444 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - NODE 255: notifyTransactionResponse TID:2366 DONE
00:12:16.445 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - ZWaveReceiveThread queue empty
00:12:16.446 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 0 out at start. Holdoff false.
00:12:16.446 [DEBUG] [zwave.internal.protocol.SerialMessage] - Assembled message buffer = 01 05 00 4A 05 00 B5
00:12:16.447 [DEBUG] [ding.zwave.handler.ZWaveSerialHandler] - NODE 255: Sending REQUEST Message = 01 05 00 4A 05 00 B5
00:12:16.448 [DEBUG] [ding.zwave.handler.ZWaveSerialHandler] - Message SENT
00:12:16.449 [DEBUG] [ZWaveSerialHandler$ZWaveReceiveThread] - Receive Message = 06
00:12:16.449 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage started: TID 2367: [WAIT_REQUEST] priority=Controller, requiresResponse=true, callback: 0
00:12:16.451 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - processReceiveMessage input 0<>128 : Message: class=null[0], type=ACK[2], dest=255, callback=0, payload=
00:12:16.452 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Received msg (0): Message: class=null[0], type=ACK[2], dest=255, callback=0, payload=
00:12:16.453 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - lastTransaction TID 2367: [WAIT_REQUEST] priority=Controller, requiresResponse=true, callback: 0
00:12:16.454 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Received msg: ACK
00:12:16.454 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - ZWaveReceiveThread queue empty
00:12:16.455 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 1 out at start. Holdoff false.
00:12:21.450 [DEBUG] [nsactionManager$ZWaveTransactionTimer] - NODE 255: TID 2367: Timeout at state WAIT_REQUEST. 3 retries remaining.
00:12:21.452 [DEBUG] [nsactionManager$ZWaveTransactionTimer] - TID 2367: Transaction is current transaction, so clearing!!!
00:12:21.453 [DEBUG] [ve.internal.protocol.ZWaveTransaction] - TID 2367: Transaction CANCELLED
00:12:21.454 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - NODE 255: notifyTransactionResponse TID:2367 CANCELLED
00:12:21.455 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 0 out at start. Holdoff false.

Please use code fences to post logs. It helps a lot with readability.

Did you try to factory reset the device before including it?

Dear R27:

I tried including the sensor through the paper UI and i take of the battery for 1 minute, for some reason it doesn’t detect the sensor, i got a zipabox, but with this hub no problem?

Dear MArk:

I tried resetting through another hub but for some reason it’s not detected, but it happens only with this device!!! Also i tried excluding from habadmin but it doesn’t detect it. I took out the battery for 30 minutes and nothing.

Maybe its defective.