EH403 - Motion alarm report

Hi,

I just recently installed an EH403 however I did not find a way to get the PIR event during the day (when the projector is off). It seems that this device can be used for motion detection like the SP816 (everspring). I made some test and saw frames coming to the controller when motion is detected during the day (the projector is off). Is there a channel missing in the configuration file ?

I just investigated further the problem. The motion sensor used in this Everspring projector seems to be the HomeSeer HS-FLS100+ (based on the same firmware). I had a look in the OpenHab xml description of this device. There is a dedicated channel to get an event when a motion is detected. Thus it is probably missing in the xml description of the EH403 (note that I am not an expert of the zwave protocols, be indulgent ;-))

1 Like

I just looked at our database entry and there is a Motion alarm channel defined.


It is also defined in the OH XML file in the binding

      <channel id="alarm_motion" typeId="alarm_motion">
        <label>Motion Alarm</label>
        <properties>
          <property name="binding:*:OnOffType">COMMAND_CLASS_ALARM</property>
        </properties>
      </channel>

That database entry was last updated in February. What version of openHAB are you running?

Thank you so much to have solved the issue. I have OpenHab 2.5.0 running on my Synology. I downloaded 2.5.7 on my mac with the zwave USB stick I used on the Synology. Verdict: motion detection works fine with 2.5.7 on MacOS. I compared the two OH XML. In 2.5.0, it was

  <channel id="alarm_burglar" typeId="alarm_burglar">
    <label>Alarm (burglar)</label>
    <properties>
      <property name="binding:*:OnOffType">COMMAND_CLASS_ALARM;type=BURGLAR</property>
    </properties>
  </channel>

So a bit different from the current entry.

I have thus to update the Synology with the latest OH release without breaking what I did with the older version.

Thanks again for you valuable help.

That is probably the best path. After you update, delete the Thing from OH ( do NOT exclude from the network) and rediscover to get the new binding information.

Unfortunately the Synology Package is not yet available for 2.5.7. Only 2.5.2 is available so far. Maybe it is the right moment to move to Docker. I have had too many issues with the Synology pkg.

Thanks again

2.5.2 should work.

I updated first the synology package to 2.5.2. I removed the thing and rediscovered it again. Unfortunately, I have the same channels than for 2.5.0. I have an “Alarm (burglar)” channel instead of a “Motion Alarm” channel I found with 2.5.7 on the mac.

Not sure when 2.5.2 was released, Are you able to manually install bindings? Updating that may be the easier way.

2.5.2 was released Feb 19. The device was last updated on Feb 18. Perhaps the latest changes did not make it to 2.5.2

I checked the console, and the version number that is displayed is 2.5.0. So maybe a problem occurred during the installation of the new version of the package. So I did again a fresh install of 2.5.2 and did not update it with my conf files and all the files/dir within userdata. And then I got the new channel “Motion Alarm”. I tested the item attached to it. It works perfectly !

Then I have now to proceed carefully extracting files from my 2.5.0 userdata since I suspect it has generated the problems I had with the first installation. I saw several “2.5.0” files in the tmp sub directory. May be not all directories should be taken from my 2.5.0 userdata. I will manage that, do not spend more time on my issue which is not anymore related to the topic. Thanks again for your help.

1 Like

I know 2.5.1 & possibly 2.5.2 still showed 2.5.0.

Problems fully solved. I installed 2.5.2 again and I carefully selected the userdata directory/files to recover. But the update is not so obvious to perform. Thank you very much again for your help.

1 Like

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.