Empty page after admin login at mobile devices (HTTPS, OH3, MainUI, iOS)


i got a problem with admin access on my mobile devices:

  1. I open OH3 ( at Safari (iOS14.3, iPhone12 and iPhone SE)
  2. Overview page opens, everything is fine
  3. I save the link to homescreen and open it, everything is fine
  4. I login as admin and still everything is fine
  5. I close OH3 on iPhone and open it again from home screen: i just see an empty page, no errors oder warnings
  6. I open OH3 directly in Safari: Same here, just an empty page
  7. After deleting website data it works again

When i open it with http instead of https, it works fine.
Why does https always just works “at first time” ?

Thanks, Alex

What are you using for an ssl certificate?

I didnt create a ssl certificate, yet.

https needs a certificate to function.

Of course, but i always thought, its created automatically at first installation:

Are further steps are necessary at OH3? On OH2.5 i had no problems with it.

There is one but the hostname / ip address would not match your server. Many browsers would refuse to display with a mismatched certificate fearing a man-in-the middle attack.

Thanks, i think this is the reason for it: I changed the ip of my oh3 instance.

Now i renewed the cert with this command an restartet oh3, but i still got the same problem (deleted website data on mobiles, too)

sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/ssl/openhab.key -out /etc/ssl/openhab.crt

That still will not likely be trusted by your browser. Some people use LetsEncrypt for free certificates.

But why is it accepted just at first time? Found out that it is not depending on the admin login - happens everytime i close the “app” and open it again.
In generell there should be no problem with the certificate - before changing the ip it worked already.

Is it possible, that the path to the cert changed in oh3 and the path in docs isnt correct anymore?

connecting to a https site via browser you can examine the certificate that is being used on the server site. Doing this you should be able to identify if your latest version of the certificate is being used.
I agree that in case of an invalid certificate you at least should be able to see a warning message of the browser that the site is not being trusted - and - in that case the initial connection needs to show the same behavior.

I am not sure, but i think the cert didnt get updated.

Today i tried the following steps - without success:
1.dpkp-reconfigure openhab
2. uninstall & new install of openhab

After the reinstall of openhab the timestamp of the manually created certs didnt change, so i think the oh-created cert is safed at another path?

There are different certificates being used in OH.
One in case you use a reverse proxy ( e.g. nginx ) and one in the keystore.
Which one did you change resp. how do you want to use it ?

Actually i dont use a reverse proxy. At home i can reach the server directly, when i am not at home i connect through myopenhab.org.

So you stored your certificate in the keystore then ?

No, no further manual actions.

For testing I installed a new OH3 instance in a separate VM. The same problem exists here.

Then the original created certificate is being used.
But as you already conlcuded that shouldn’t be the reason.

Additional info:
When i just close the tab and open a new one (without deleting browser data) on my mobile, the site is loading again - until i close and reopen the browser again.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.