Enocean Binding USB 300 on Synology DSM 6.2 Docker OpenHab 3.0.1 DS716II

a lot of effort has been put into setting up openhab by means of the manuals
openhab within Docker part of the install packages of Synology
in combination of the installation guide of Docker USB sticks

after some testing I want to start over with a clean slate but:

  1. installed Docker on DSM 6.2
  2. installed Openhab 3.0.1 as container
  3. created the volumes
  4. Openhab runs
  5. installed Enocean Binding
  6. add The EnOcean gateway, unfortunately this does not work.
    I add the required path for the gateway = /dev/ttyUSB0

***: ~ $ lsusb

| __3-1 0403: 6001: 0600 00 2.00 12MBit / s 90mA 1IF (EnOcean GmbH EnOcean USB 300 DC FT4YFL3J)

***: ~ $ ls -lisa / dev / ttyUSB0
934 931 0 crw-rw-rw- 1 root root 188, 0 Apr 11 20:13 / dev / ttyUSB0

***: ~ $ dmesg | grep usb

[22472.763381] usb 3-1: FTDI USB Serial Device converter now attached to ttyUSB0

can someone point me in the right direction please?

in code:

UID: enocean:bridge:b56894b0c1
label: EnOcean Gateway
thingTypeUID: enocean:bridge
rs485BaseId: “00000000”
path: /dev/ttyUSB0
rs485: false
espVersion: ESP3


You need to check “Execute container using high privilege” in the tab General settings in the UI of Docker?

and from the Documentation:

USB sticks

If you want use an USB stick (for example for Z-Wave network), then it will be not available for the dockerized system by default. In Docker openHAB is running in name of openhab, a restricted user. The stick will work if you run the following command right after docker image is started.

(in my case)

docker exec \
    -d \
    openhab-openhab1 \
    /bin/chmod o+rw /dev/ttyUSB0

when you start the container after a stop you need execute the command again

This command changes permissions of the specific device as expected (readable and writable for everyone).


The device path (/dev/ttyACM0) or container name (openhab) could be different in your system, command can be modified accordingly.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.