Enocean missing constraint: gnu.io

Hi all,
I’am trying out with openhab1 and would like to use it for my thesis.
I have an enocean gateway with Rocker switch. My problem is:

On build, I have no errors, however when I run the openhab project, I get the messages below:

In the eclipse Validation dialog

The following problems were detected:

  • Missing constraint: Import-Package: gnu.io; version=“0.0.0”

when I continue with run, I get a message on the console.

Console messege

“MESSAGE Bundle reference:file:…/openhab1.8/bundles/binding/org.openhab.binding.enocean/ was not resolved.
!SUBENTRY 2 org.openhab.binding.enocean 2 0 2015-11-20 16:40:57.858”


I assume, there is a missing bundle that is responsible for exporting the package “gnu.io
Which bundle is that?
If the bundle is not in the openhab project from git, where can I get it?

What I have tried so far:

I have added “RXTXcomm.jar” to my “…\jdk1.8.0_65\lib”. But this has not helped.

I got this solved. For those who may have the same problem:
Download files “rxtxSerial.dll” and “RXTXcomm.jar”

  • “rxtxSerial.dll” to your Jdk e.g. “C:…\Java\jdk1.8.0_65\jre\bin”
  • “RXTXcomm.jar” to your Jdk e.g. “C:…\jdk1.8.0_65\jre\lib\ext” (contains gnu.io package)
    Now inlclude the bundle"org.openhab.io.transport.serial" to the set of plug-ins that should be resolved
    in the “set Configuration” dialog, by selecting it in the checkbox.

I hope that will help some body. Thanks