Error 500 when editing zwave things after binding install / uninstall

Hi all,

my setup is:

Raspberry Pi 3B+ with 16GB SD

Openhabian with openHAB 2.4 stable

I keep having trouble with a recurring Error 500 in Paper UI. It shows up every time I try to edit a zwave thing in Paper UI (e.g. changing the thing name). At the same time most of the settings for zwave things in Habmin are gone (parameters and association groups). This occurs every time I installed or uninstalled a binding via Paper UI. The only way to get rid of the error is to uninstall the zwave binding and reinstall it via the Zwave and Zigbee Manual Installer Script.

Apparently this issue has already shown up in a snapshot version, fixed in a later one. However, when upgrading to 2.5 (where this fix should be incorporated, if my understanding of version numbers is correct) it still persisted on my system.

For clarification here is the sequence in chronological order:

  1. Everything is working fine, all settings for zwave things in Habmin are present, no Error 500 is shown in Paper UI when editing zwave things.

  2. I install or uninstall any binding via Paper UI.

  3. Error 500 is shown every time I edit a zwave thing in Paper UI. At the same time parameters and association groups for zwave things are gone in Habmin.

  4. I uninstall the zwave binding via Paper UI.

  5. I reinstall the zwave binding via the Manual Installer Script.

  6. see 1.

Right now this is just a little bit of a nuisance since I know how to solve the issue. I suspect, however, this might have a common cause with other problems I am having. I recently updated to 2.5 stable but was unable to run it permanently as I ran into the recurring ‚System started‘ trigger encountered by several users (see here). During troubleshooting I somehow managed to break the system completely so had to roll back to a backup and 2.4. I afterwards decided to first tackle those small problems evidently present in my system and then try and update again.

I believe to have read all threads relating to the infamous Error 500 but no one seems to have had exactly this sequence of events when encountering the error. Following commonly given advice I have already tried clearing the cache and restarting several times, but to no avail.

A few things which might or might not be connected to the Error 500 issue:

  • In my addons folder there are two jar-files (org.apache.servicemix.bundles.xstream-1.4.7_1 and org.openhab.binding.zwave-3.0.0-SNAPSHOT). The latter one obviously stems from manually installing the zwave binding. The first one I am not sure about when and how it got there. I cannot remove either file, otherwise all my zwave things will come up as uninitialized upon next restart. Are those files supposed to be there? After reading a few threads on that my understanding is they are only required upon first installation of the binding and should be removed thereafter.

  • As mentioned above after updating to 2.5 my rule with ‚System started‘ trigger was triggered frequently. This happened every time a zwave thing had been changed (e.g. change of parameter). I do not know whether this could be connected to the Error 500 issue, but editing zwave things seems to play a role in all those issues suspiciously often.

  • Some time ago my openhab.log stopped being written to. After some time it was possible to solve that by simply deleting the file and having openHAB create a new one.

Maybe all this info helps in pointing me in the right direction. Does anyone have an idea on how to further troubleshoot this? My last resort would be to wait for the next update due next week and then start with a fresh installation. Still, given the time required I would still prefer to be able to fix this issue.

You are trying to run a 3.0 Snapshot binding on 2.4 3.0 is not even functional yet.
The recommendation from our Z-Wave developer for a while has been to upgrade to 2.5. The stable version was released last month. If you have restdocs installed it would be best to uninstall it and reinstall after upgrading. Also remove those jar files from the addons folder first.

Ah, that makes sense! Interestingly, it is exactly the file being downloaded by the Zwave Manual Install Script when choosing the recommended ‘Snapshot’ option:

 *****     SUMMARY     *****     

Addons path: /usr/share/openhab2/addons
OpenHAB account: openhab
Requested action: Install or upgrade Z-Wave binding
Current OpenHAB snapshot version: 3.0.0
Requested Z-Wave version: OpenHAB snapshot

Is this correct?
1) Yes, start now
2) No, take me back to the first menu
3) Exit

I uninstalled the zwave binding now, deleted those jar-files and reinstalled the zwave binding via Paper UI. That seems to have solved it - no Error 500 in sight!

I will try and update to 2.5 again later. During my first try I uninstalled restdocs as per the update instructions. Would I have to additionally remove them from addons.config? After uninstalling they were still listed under ‘misc’.

The install script has been broken since 2.5 was released and things were reorganized for OH3.

I am quite sure the 3.0 jar had been downloaded by the script way before 2.5 was released. I could be mistaken, though, maybe I downloaded it manually when starting to fiddle with binding updates. That’s the problem when doing stuff based on solid half-knowledge, or worse, solid half-understanding: you never know what you get.

In any case, the Error 500 issue is solved and I was able to update to 2.5 again. The system started error still persists; will have to go with a workaround there until more information is gathered.

Thanks a lot for your help, @Bruce_Osborne! That was most valuable!

This is not possible since the version numbers weren’t changed until well after the 2.5 release :wink:

1 Like

In that case it probably comes down to my solid half-understanding… The one lesson I have learned from spending lots of hours troubleshooting this is to only start something I have thoroughly understood.