Error: Autorefresh: Cannot read value for item 'Light_FF_Bath_Mirror' from KNX bus: timeout waiting for group read response: timeout

Hi there,

its my first try with openHab. I know a lil about KNX and got my Berker Server running and working. Now i know the Berker software is not the final solution…

It seems to be that finally i got a connection, but when i use the client to test the light switch nothing happens in real. The switch moves, but the real light doesnt react.

I found the following lines in debug mode:

18:23:27.734 [ManagedService Update Queue] DEBUG o.o.b.k.i.connection.KNXConnection - Success: connected.
18:23:27.734 [KNXBinding/DatapointReaderTask] DEBUG o.o.b.k.i.b.KNXBindingDatapointReaderTask - Autorefresh: got new item Light_FF_Bath_Mirror in reader queue
18:23:27.735 [KNXBinding/DatapointReaderTask] DEBUG o.o.b.k.i.b.KNXBindingDatapointReaderTask - Autorefresh: Trying to read form KNX bus: state DP 1/0/42 Light_FF_Bath_Mirror, DPT main 0 id 1.001, low priority
18:23:27.735 [KNXBinding/DatapointReaderTask] DEBUG o.o.b.k.i.b.KNXBindingDatapointReaderTask - Autorefresh: Sending read request to KNX for item 'Light_FF_Bath_Mirror' DPT '1.001'
18:23:27.739 [NTP Refresh Service] INFO  o.o.c.service.AbstractActiveService - NTP Refresh Service has been started
18:23:27.739 [NTP Refresh Service] DEBUG o.o.binding.ntp.internal.NtpBinding - There is no existing NTP binding configuration => refresh cycle aborted!
18:23:27.740 [Log dispatcher] INFO  tuwien.auto.calimero - [KNXBinding/DatapointReaderTask] link 224.0.23.12:3671: send message to 1/0/42, wait for confirmation
18:23:27.740 [Log dispatcher] DEBUG tuwien.auto.calimero - [KNXBinding/DatapointReaderTask] link 224.0.23.12:3671: cEMI L-Data.ind from 0.0.0 to 1/0/42, low priority hop count 6 repeat tpdu 00 00
18:23:27.742 [Log dispatcher] DEBUG tuwien.auto.calimero - [KNXBinding/DatapointReaderTask] KNXnet/IP Routing 224.0.23.12:3671: sending cEMI frame, non-blocking, attempt 1
18:23:27.742 [Log dispatcher] DEBUG tuwien.auto.calimero - [KNXBinding/DatapointReaderTask] link 224.0.23.12:3671: send to 1/0/42 succeeded
18:23:27.742 [Log dispatcher] DEBUG tuwien.auto.calimero - [KNXBinding/DatapointReaderTask] process link 224.0.23.12:3671: sent group read request to 1/0/42


18:23:37.749 [Log dispatcher] INFO  tuwien.auto.calimero - [KNXBinding/DatapointReaderTask] process link 224.0.23.12:3671: timeout waiting for group read response
18:23:37.749 [KNXBinding/DatapointReaderTask] WARN  o.o.b.k.i.b.KNXBindingDatapointReaderTask - Autorefresh: Cannot read value for item 'Light_FF_Bath_Mirror' from KNX bus: timeout waiting for group read response: timeout
18:23:37.749 [KNXBinding/DatapointReaderTask] WARN  o.o.b.k.i.b.KNXBindingDatapointReaderTask - Autorefresh: Remaining retries for address '1/0/42' = '2'
18:23:37.750 [KNXBinding/DatapointReaderTask] DEBUG o.o.b.k.i.b.KNXBindingDatapointReaderTask - Autorefresh: DatapointReaderTask Waiting 50 msecs to prevent KNX bus overload
18:23:37.778 [Scanner-2] DEBUG org.eclipse.jetty.util.Scanner - scanned [/Applications/openHab/contexts]: {}
18:23:37.779 [Scanner-1] DEBUG org.eclipse.jetty.util.Scanner - scanned [/Applications/openHab/webapps]: {}
18:23:37.800 [KNXBinding/DatapointReaderTask] DEBUG o.o.b.k.i.b.KNXBindingDatapointReaderTask - Autorefresh: Waiting for new item in reader queue
18:23:37.800 [KNXBinding/DatapointReaderTask] DEBUG o.o.b.k.i.b.KNXBindingDatapointReaderTask - Autorefresh: got new item Light_FF_Bath_Mirror in reader queue
18:23:37.801 [KNXBinding/DatapointReaderTask] DEBUG o.o.b.k.i.b.KNXBindingDatapointReaderTask - Autorefresh: Trying to read form KNX bus: state DP 1/0/42 Light_FF_Bath_Mirror, DPT main 0 id 1.001, low priority
18:23:37.801 [KNXBinding/DatapointReaderTask] DEBUG o.o.b.k.i.b.KNXBindingDatapointReaderTask - Autorefresh: Sending read request to KNX for item 'Light_FF_Bath_Mirror' DPT '1.001'
18:23:37.801 [Log dispatcher] INFO  tuwien.auto.calimero - [KNXBinding/DatapointReaderTask] link 224.0.23.12:3671: send message to 1/0/42, wait for confirmation
18:23:37.802 [Log dispatcher] DEBUG tuwien.auto.calimero - [KNXBinding/DatapointReaderTask] link 224.0.23.12:3671: cEMI L-Data.ind from 0.0.0 to 1/0/42, low priority hop count 6 repeat tpdu 00 00
18:23:37.802 [Log dispatcher] DEBUG tuwien.auto.calimero - [KNXBinding/DatapointReaderTask] KNXnet/IP Routing 224.0.23.12:3671: sending cEMI frame, non-blocking, attempt 1
18:23:37.802 [Log dispatcher] DEBUG tuwien.auto.calimero - [KNXBinding/DatapointReaderTask] link 224.0.23.12:3671: send to 1/0/42 succeeded
18:23:37.802 [Log dispatcher] DEBUG tuwien.auto.calimero - [KNXBinding/DatapointReaderTask] process link 224.0.23.12:3671: sent group read request to 1/0/42

i tried it with the native ios client and the via web browser.

my config :
# KNX gateway IP address
# (optional, if serialPort or connection type ‘ROUTER’ is specified)
#knx:ip=192.168.1.173

# Local KNX Binding bus address.
# Use it, when two or more openHAB Instances are connected to the same KNX bus.
# (optional, defaults to 0.0.0)
#knx:busaddr=

# Ignore local KNX Events, prevents internal events coming from
# 'openHAB event bus' a second time to be sent back to the 'openHAB event bus'.
# Note: To send back events second time is a Bug, but for backward compatibility, the behavior is not changed.
# For new installations, its recommend to set "knx:ignorelocalevents=true"
# (optional, defaults to false)
#knx:ignorelocalevents=

# KNX IP connection type. Could be either TUNNEL or ROUTER (optional, defaults to TUNNEL)
# Note: If you cannot get the ROUTER mode working (even if it claims it is connected),
# use TUNNEL mode instead with setting both the ip of the KNX gateway and the localIp.
knx:type=ROUTER

# KNX gateway port (optional, defaults to 3671)
# Note: If you use eibd, setting to 6720
#knx:port=

# Local endpoint to specify the multicast interface, no port is used (optional)
knx:localIp=15.15.254

# Serial port of FT1.2 KNX interface (ignored, if ip is specified)
# Valid values are e.g. COM1 for Windows and /dev/ttyS0 or /dev/ttyUSB0 for Linux
knx:serialPort=COM1

# Pause in milliseconds between two read requests on the KNX bus during
# initialization (optional, defaults to 50)
#knx:pause=

# Timeout in milliseconds to wait for a response from the KNX bus (optional,
# defaults to 10000)
#knx:timeout

# Number of read retries while initialization items from the KNX bus (optional,
# defaults to 3)
#knx:readRetries

# Seconds between connect retries when KNX link has been lost
# 0 means never retry, it will only reconnect on next write or read request
# Note: without periodic retries all events will be lost up to the next read/write
#       request
# (optional, default is 0)
#knx:autoReconnectPeriod=30

### Auto refresh feature
# Number of entries permissible in the item refresher queue.
# (optional, defaults to 10000)
#knx:maxRefreshQueueEntries=

# Number of parallel threads for refreshing items. (optional, defaults to 5)
#knx:numberOfThreads=

# Seconds to wait for an orderly shutdown of the auto refresher's
# ScheduledExecutorService. (optional, defaults to 5)
#knx:scheduledExecutorServiceShutdownTimeoutString=

I don´t have any idea what could be wrong. Maybe there is a limitation or restriction accessing the bus via the Berker IP KNX Gateway?

Thanks for any help.

regards
thomas

no idea? someone?

I don’t know if your native language is German, but on this German forum there are a lot of KNX experts.