Error by integrate z-wave

Hello community,

I have a problem with connect my OpenHAB software with the Z-Wave software:

I have a raspi 3 which installed openhabian. Also I have installed a z-wave hardware.
The z-wave console work very fine. I can switch on/off my single electrical outlet.

Now I want to integrate z-wave in OpenHAB.

So I put in Paper UI -> Configurations -> Things -> Z-Wave Serial Controller in SerialPort /dev/ttyAMA0 .
I have checked the port number in the linux console.

Unfortunately OpenHab get me an error: “Status: OFFLINE - COMMUNICATION_ERROR zwave.thingstate.serial_notfound”

What can I check to fix the error?

Thank you very much and regards
Michael

Did you add the openhab user to the dialout or tty group (depending on your operating system) as described in the ZWave readme?

Hello,
I can not found the readme file from my z-wave.
I have a RaZberry2 and I get this manual with my z-wave für my raspi:

How can I add the openhab user?
Thank you!

With “ZWave readme” the readme of the official docs were meant:

http://docs.openhab.org/addons/bindings/zwave/readme.html

The specific section for adding the user to the dialout group can be found in the readme of the linux installation page:

http://docs.openhab.org/installation/linux.html#privileges-for-common-peripherals

sudo adduser openhab dialout
sudo adduser openhab tty
1 Like

Now I have added the user:

[12:26:29] openhabian@openHABianPi:~$ groups openhab
openhab : openhab tty dialout audio gpio

But the same error occured: Status: OFFLINE - COMMUNICATION_ERROR zwave.thingstate.serial_notfound

There are many parameter in the “Configuration Parameters”.in PaperUI
I have set only the “Serial Port” with “/dev/ttyAMA0”, many other parameter are set default (e.g. Network Security Key, Inclusion Mode Timeout)

What other parameters do I have to set?

What does “ls -l /dev/tty*” look like? Are you sure your device is not “/dev/ttyACM0” or something different than AMA0 ?

Nothing. All you need is the port (shown in HABmin):

1

And make sure, as miker already suggested, to find the correct port for your hardware.

Thank you, for helping.
I have reboot the raspi and not it works.