Error in doSet - no database found

I finally have my 2 Fibaro sensors paired to my z-wave stick. I verified they are on Node 4 and 5. Both of them show green dots next to the Node value in HABmin and the correct Value (Fibaro System [ID:2001, Type 801]).

The issue I’m now having is that when I try to add a Name or Location to the sensor, it disappears after a couple of seconds and the log shows Node 4: Error in doSet - no database found.

I searched and found someone with the same issue who excluded and then included each of these devices and waited a couple of hours for HABmin to find the devices again. I followed that advice, but I’m still getting the same error messages trying to save the name and/or location for both sensors.

What are the devices you’re talking about? I’ll check if they are in the database, but I need to know what they are ;).

Fibaro Multisensor (FIB_FGMS-001)

I’m using the layout below in my items file:

Number Movement “Movement: [%s]” { zwave=“4:command=sensor_binary” }
Number Alarm “Alarm: [%s]” { zwave=“4:command=sensor_alarm” }
Number Lux “Lux: [%.2f Lux]” { zwave=“4:command=sensor_multilevel,sensor_type=3” }
Number Bat “Battery: [%d %%]” { zwave=“4:command=battery” }
Number Temp “Temperature: [%.1f °C]” { zwave=“4:command=sensor_multilevel,sensor_type=1” }

It looks like this device is in the database - what version of the binding are you using?

Can you also post the actual log entry please - possibly the error, and some data from a bit before the error (especially if you have a debug log).

The z-wave binding is org.openhab.binding.zwave-1.8.3

Here is the log for the z-wave binding:

2016-09-05 19:16:10.771 [INFO ] [.z.internal.ZWaveActiveBinding] - Update config, port = /dev/ttyACM0
2016-09-05 19:16:10.772 [INFO ] [.z.internal.ZWaveActiveBinding] - Update config, healtime = 2
2016-09-05 19:16:10.774 [INFO ] [.service.AbstractActiveService] - ZWave Refresh Service has been started
2016-09-05 19:16:10.842 [INFO ] [b.z.i.protocol.ZWaveController] - Starting Z-Wave controller
2016-09-05 19:16:10.843 [INFO ] [b.z.i.protocol.ZWaveController] - Z-Wave timeout is set to 5000ms. Soft reset is false.
2016-09-05 19:16:10.844 [INFO ] [b.z.i.protocol.ZWaveController] - Connecting to serial port /dev/ttyACM0
2016-09-05 19:16:10.944 [INFO ] [b.z.i.protocol.ZWaveController] - Serial port is initialized
2016-09-05 19:16:13.783 [INFO ] [.o.b.w.i.s.WeatherJobScheduler] - Starting and scheduling weatherJob-home with interval of 10 minutes
2016-09-05 19:16:14.241 [INFO ] [rialApiGetInitDataMessageClass] - NODE 1: Node found
2016-09-05 19:16:14.244 [INFO ] [rialApiGetInitDataMessageClass] - NODE 4: Node found
2016-09-05 19:16:14.246 [INFO ] [rialApiGetInitDataMessageClass] - NODE 5: Node found
2016-09-05 19:16:14.249 [INFO ] [rialApiGetInitDataMessageClass] - ZWave Controller using Controller API
2016-09-05 19:16:14.251 [INFO ] [rialApiGetInitDataMessageClass] - ZWave Controller is Primary Controller
2016-09-05 19:16:14.254 [INFO ] [rialApiGetInitDataMessageClass] - ------------Number of Nodes Found Registered to ZWave Controller------------
2016-09-05 19:16:14.257 [INFO ] [rialApiGetInitDataMessageClass] - # Nodes = 3
2016-09-05 19:16:14.259 [INFO ] [rialApiGetInitDataMessageClass] - ----------------------------------------------------------------------------

This is the line I get in the log when I try to update the name:

2016-09-05 19:23:34.661 [ERROR] [.z.i.config.ZWaveConfiguration] - NODE 4: Error in doSet - no database found

I would suggest first to update to the last version of the zwave binding (1.9 snapshot). The 1.8.3 version had a broken database so to make sure this isnt the issue, it’s best to use the latest nightly snapshot.

OK, sorry for the REALLY noob question, but how do I install the latest binding. It seems like the guide that I followed to install the binding was from November 2015.

I downloaded the file from the z-wave binding wiki, but do I just replace the .jar file, or is there an install that I need to run?

The nightly snapshot is available on the cloudbees server. You can download just the new ZWave binding JAR and replace the binding in your addons folder.$org.openhab.binding.zwave/

1 Like

That worked! Thanks SO much!!