Error in the log file Unresolved requirement: Import-Package: org.apache.commons.lang

I downloaded the jar file for a fuzzy logic binding from https://github.com/ansz74/org.openhab.action.jfuzzylogic/raw/master/target/org.openhab.action.jfuzzylogic-1.9.0-SNAPSHOT.jar

I put the jar file in the addons folder

However when I looked at the event log it says there is an error

When I searched the forums to see if anyone else had experienced the same issue I found this person saying there was an issue but its was solved

  • Platform information:
    • Hardware: CPUArchitecture/RAM/storage
    • OS: Windows 10
    • Java Runtime Environment: Zulu11.45+27-CA (build 11.0.10+9-LTS)
    • openHAB version: openhab-3.1.0

That appears to be an addon for OH1. OH1 addons just aren’t supported at all by OH3, so I’m not sure there’s much you can do here.

1 Like