Error installing/starting OpenHab2 after manual installation on existing RetroPie install

Hi All, wondering if you can help please or point me in the right direction. I’m opting to try OpenHab 2 on my existing Raspberry Pi 3B+ as earlier today I wiped the default pi os and installed RetroPie to get more out of the hardware, as all it was doing was running Pi Hole. Now it boots to RetroPie as the front end and I reinstalled Pi Hole to run in the background. So I don’t really want to wipe the SD card again and use the OpenHab OS image as I’m only trying this out to see if it’s worth pursuing personally.

I followed the manual instructions for the package repository installation method and all seemed to be going well. But when I run the following commands as directed the program exits out with a status=1/FAILURE.

sudo /etc/init.d/openhab2 start
sudo /etc/init.d/openhab2 status

sudo update-rc.d openhab2 defaults

I also tried:

sudo systemctl start openhab2.service
sudo systemctl status openhab2.service

sudo systemctl daemon-reload
sudo systemctl enable openhab2.service

And here was the output:

Is there a conflict between Pi Hole and OpenHab2 due to Pi Hole installing a webserver?

  • Platform information:
    • Hardware: Raspberry Pi 3B+
    • OS: RetroPie latest / Linux 4.19.50-v7+ armv71
    • openHAB version: latest stable

Thanks,
Scott