Error on rrd4j persistence


I get this problem with RRD4J persistence (I didn’t test with other services though):

2017-03-17 12:48:16.035 [WARN ] [el.core.internal.ModelRepositoryImpl] - Configuration model 'rrd4j.persist' has errors, therefore ignoring it: [1,1]: mismatched input '<EOF>' expecting 'Strategies'

I cannot figure out where the problem comes from, as my rrd4j.persist file looks fine to me:

Strategies {
	everyMinute : "0 * * * * ?"
	everyHalf : "0 30 * * * ?"
	everyHour : "0 0 * * * ?"
	everyDay : "0 0 0 * * ?"

	default = everyUpdate, restoreOnStartup

Items {
	gSensors* : strategy = everyChange, restoreOnStartup
	gPIR* : strategy = everyChange, restoreOnStartup
	gPIRAus* : strategy = everyChange, restoreOnStartup
	gSMOKE* : strategy = everyChange, restoreOnStartup
	gVirtual* : strategy = everyChange, restoreOnStartup
	gLight* : strategy = everyChange, restoreOnStartup
	gMeter* : strategy = everyMinute, restoreOnStartup
	gMeterHour* : strategy = everyHour, restoreOnStartup
	gMeterDaily* : strategy = everyDay, restoreOnStartup
	PERSIST_SMETER_Total_kWh : strategy = everyUpdate, restoreOnStartup
	PERSIST_SMETER_Total_kWh_daily : strategy = everyUpdate, restoreOnStartup
	STATE_AUTO_Belueftung : strategy = everyUpdate, restoreOnStartup
	STATE_PIR_UG_ACTIVE : strategy = everyUpdate, restoreOnStartup
	STATE_PIR_ACTIVE : strategy = everyUpdate, restoreOnStartup
	Network_WAN_IP : strategy = everyUpdate, restoreOnStartup

Does anybody have an idea what I’m doing wrong? I am on openHAB2 latest unstable build from apt repository on Debian (x86_64). Thanks a lot in advance!

Can’t say if that is the reason for your error but rrd4j needs to save every minute!

I have this error sometimes when using Eclipse SmartHome Designer. Edit the persistence file via


or your preferred editor, directly on Raspberry, and save it.
I my cases the error just vanishes, and also does not reappear when doing the next changes via SmartHome Designer again.


I have the same problem with this one, here is a screen shot from Notepad ++

The error for the record:

Configuration model ‘rrd4j.persist’ has errors, therefore ignoring it: [1,1]: mismatched input ‘’ expecting ‘Strategies’

I would be greatfull for any help.

I found the error, in line 5 there are some empty spaces, when they were deleted it worked :smiley:

You’re kidding me, aren’t you? So easy to solve the problem…

So it might be a good idea to have OpenHAB trim each line when parsing them.

I can’t confirm that it works but I’m not getting the same “Configuration model ‘rrd4j.persist’ has errors, therefore ignoring it: [1,1]: mismatched input ‘’ expecting ‘Strategies’” error nor any other errors, so maybe :slight_smile:

I discovered that using an other editor helped. I moved from working with notepad ++ to microsoft visual studio and then I didnt see the error anymore.

Are you sure on that? Or is it Visual Studio Code with the openHAB Extension?

Are you questining the name or if the error is solved by using the visual studo?

I think is microsoft visual studio, this is what the help file says:

I was questioning the “microsofg visual studio”, sincd the actually suggested editor for OH is “visual studio code”. Sounds similar but it isn’t!
The later has (with the openHAB extension) code highlighting etc.!