[ERROR] org/joda/time/DateTime

After updating OpenHab (Openhabian) i get.

[ERROR] [ntime.internal.engine.RuleEngineImpl] - Rule ‘heat living’: An error occurred during the script execution: org/joda/time/DateTime

My Rule:

rule "heat living"

	Item Temp_kitchen received update or Item Temp_kitchen_setpoint received command
var Number setValue = Temp_kitchen.state as Number
var Number tarValue = Temp_kitchen_setpoint.state as Number

if (setValue.floatValue >= tarValue.floatValue)
{sendCommand(acc_living, OFF)}
{sendCommand(acc_living, ON)}

Hope somone can give a hint.


If Temp_kitchen and Temp_kitchen_setpoint are Numbers and acc_living is a Switch you sould not get any errors.

Another thought, if this happened immediately after updating, try to restart OH2 once or twice (giving it a few minutes in between), not sure whether you are on the stable or the snapshot version, but I have had seemingly random errors after updates for quite some time (on snapshot version though);

Have both number-item a valid value (not NULL)?

Both Temp_kitchen and Temp_kitchen_setpoint are Numbers

And acc_living is a Switch

They jave both a value

Temp_kitchen has the actual temp value (for the moment 26,1)
Temp_kitchen_setpoint is sat to 22

But as long as i get the arror i cant turn it off thats why the high temp


I have tried that a few times but didnt help.

I’m running a stable vesion - the last update (yesterday)

I forgot to mention that its not only my heating rules but also my Hue ruels that generate errors.

Is this the only rule that takes this name?

No all my heating and HUE rules are failing

I mean, have you checked that there is no other rule with the same name?
Else, you can try to change/reduce the statements in when and/or then, to check if the error changed also.

I´ll try that, but everything worked until i updated :-/