Error: Web Socket close 1005. Reason: null

Dont know.
I de-installed 3.2.9 now and just installed 3.2. Did no change to the things or the account-thing. After installing 3.2 its working again. The http(s)://:/amazonechocontrol/account1 shows all my devices.
However, after de-installing 3.2 again and installing 3.2.9 again all things are again offline and log-in doesnt work. Still did no change to all the things.

One side information: After login didnt work with 3.2.9 i deleted the old account-thing (text based thing) and created a new one in 3.2.9 in the UI. Maybe this is the issue.

Think i will stay now at 3.2 and wait for an update. Can you just post a short notification here so that i can recognize it? :slight_smile:

If it works on 3.2, switching to 3.2.9 should work. If that doesn’t work, there is another issue. It could be related to the text-based thing definition. I recommend to never use that and can‘t provide any support for that.

The process i did:

  1. De-install 3.2
  2. Install 3.2.9
  3. All things offline, Removed text-based account-thing because log in didnt work
  4. Created a UI-based account-thing with the same name
  5. Log-in still didnt work
  6. De-installed 3.2.9, installed 3.2
  7. No log-in to amazon required, all things directly online
  8. De-installed 3.2, installed 3.2.9
  9. All things offline, Log-in didnt work
  10. De-installed 3.2.9, installed 3.2
  11. All things offline, log-in to amazon, all things online

I am on OH 3.2 stable.
I did 1. and 2. and after less than 1 minute all went online again and the web socket error disappeared :slightly_smiling_face:
Kudos to @J-N-K for his great work!

Similar issues as some here.

v3.2.0 I can set up, login etc. but get the Web Socket Error and the Amazon Echo app cannot see any of the openhab items.

On 3.2.9, I cannot log in. Error is Login to ‘’ failed: Request failed. Maybe a localisation issue? I need to log in to although I’m not sure if, for the purposes of this binding, it matters.

Please send TRACE logs of the login attempt either by PM or via mail to Do not post them here.

Please note: the „login“ (i.e. via /amazonechocontrol/account) is not working for 3.2.9. if you have an account that is logged in, it should work.

If you tried to install 3.2.9 and then tried to login via /amazonechocontrol/account, the storage is probably corrupted. I‘m currently trying to figure out what is the easiest way to resolve that.

Edit: For the Amazon App to see your items you don’t need the amazonechocontrol binding. You have to add proper metadata and install the Alexa openHAB skill.

Where do you try to login ( or another domain?) And please go to you user data folder (e.g. /var/lib/openhab on Debian based system). There should be a amazonechocontrol%3Aaccount%3A<thing-id>.json-file. In that file, do you see a session AND a sessionStorage entry or only one of them?

Hello J-N-K,
i am using german amazon, so
In the login page it say Connected to: [Change]

In the mentioned file on my RPI there is only a sessionStorage entry.

And if you just uninstall 3.2 and install 3.2.9 (while being logged in!) this is not working? Not even after a restart? Do not log out on the account page and don’t disable or change things. If that still does not work, please

  • disable the account thing
  • enable TRACE logging
  • enable the account thing
  • wait until you see an error message in the log
  • disable TRACE logging
  • send the log as described above

I did the process. Login did not work. Will try to send you the logfile as DM.

Exactly the same for me. On OH v3.2.0 Stable and performed step 1 and 2. And the issue is solved.

Kudos to @J-N-K and thanks a lot!

Hi folks,

I’ve the same log every 1m20s

2022-01-15 18:20:01.993 [INFO ] [control.internal.WebSocketConnection] - Web Socket close 1005. Reason: null
2022-01-15 18:21:14.078 [INFO ] [control.internal.WebSocketConnection] - Web Socket close 1005. Reason: null
2022-01-15 18:22:51.349 [INFO ] [control.internal.WebSocketConnection] - Web Socket close 1005. Reason: null
2022-01-15 18:24:19.551 [INFO ] [control.internal.WebSocketConnection] - Web Socket close 1005. Reason: null
2022-01-15 18:25:31.747 [INFO ] [control.internal.WebSocketConnection] - Web Socket close 1005. Reason: null
2022-01-15 18:26:57.522 [INFO ] [control.internal.WebSocketConnection] - Web Socket close 1005. Reason: null
2022-01-15 18:28:27.439 [INFO ] [control.internal.WebSocketConnection] - Web Socket close 1005. Reason: null
2022-01-15 18:29:47.271 [INFO ] [control.internal.WebSocketConnection] - Web Socket close 1005. Reason: null

How to understand if it’s an amazonechocontrol issue? and how to fix it? I’m on 3.3.0 #2690, so I was expecting the issue was already fixed. Am I wrong?

thanks for your support, much appreciated

@J-N-K sorry to bother you again on this thread, but after some search I see that my issue is like:

I’m on 3.3.0 #2690, and if I well understood from 3.2 it should be already fixed in the add-on. Or am I wrong? do I need to put there a customised jar?

thanks again for your support here


Exactly the same for me, I’m on 3.3.0 #2694 .
The version for the binding is displayed in the console as

that sounds like you installed amazonechocontrol from the OH repository …
Reading about first 15 posts in this thread as far as I understand the content that is provided via third party download smarthomej content is the one that contains the fixes.


not sure I understand why we need to download the add-on via third party smarthomej, and not the add-on in the OH repository. But I’m not an expert, so just to understand, not to blame someone (your support guys is always excellent :))

thanks for any clarification. I need to understand if I can wait for a fix in the OH repository, or better to move as situi suggested

thanks again

To my knowledge a fix for the openHAB Version is not available in the near future.

1 Like

same question was raised in this post Amazon Echo Control Error "Web socket close 1005" - Still happening on 3.2.0 - #18 by JimT
“answer” to it is in the post next to it.


Good catch.

I think we shouldn’t question this in detail, their may be something going on behind the scenes we don’t know and don’t have to know.
I am happy that we have the great working smarthome/j version(s), thx Jan.


This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.