Error while loading components of bundle org.openhab.ui.habpanel: (222)

  • Platform information:
    Raspberry 3
    Open’HABian 2.5.0~S1521-1 (Build #1521)

Hi guys,
I could need a little help.
I got the following problem when I was installing to the latest build. I needed to use openhab 2.5 because I use the SolarEdge binding and in Version 2.4 it crashes at least once per day.
Last week I was updating to the latest version already and I could not see the UIs except the ‘Openhab log viewer’ and the ‘Openhabian Help’ on the index.

I switched back to the last release of 2.4, but I still have the crashes of my binding. So I decided to update again to Build #1521. Now I can see the ‘Home Builder’, ‘Basic UI’ und ‘Paper UI’, but I don’t see the ‘HABpanel’ and get on the index site an error: “HTTP ERROR 404 - Problem accessing /habpanel/index.html. Reason: Not Found”

In the logfile I can see:
2019-02-11 12:42:30.772 [ERROR] [org.apache.felix.scr ] - bundle org.apache.felix.scr:2.1.14 (42)Error while loading components of bundle org.openhab.ui.habpanel: (222)

Maybe someone knows how to fix this problem.

Given the huge impact of, and amount of work involved in, moving the ESH framework under the OH umbrella and making the build process completely maven driven, I suggest to try 2.5.0.M1 and see if that helps.

1 Like

I still get the same error with 2.5.0.M1

So… is it better to make a completely clean installation then or reinstall somehow HABpanel?
I have only remote access, so some hints how to do this over console would be helpful.

What kind of remote acces do you mean? SSH is al you need to execute commands on the Pi.

BTW, the SE binding happens to work just fine on my system, both when I was running 2.4.0 and now with 2.5.0.M1…:sunglasses:

I am using SSH to control the Pi, but I have an Openhabian image. So if I need to make a new image on the microSD-card I need to be there physically to start from scratch.
I use SolarEdge binding. It it working for some time, but then it does not send any data after some time on 2.4.0.
I was trying the nighly builds of 2.5 and they were working for some time and the SE binding was working without an issue. But for a month or so the panels did not show up. In the latest build only the HABpanel that I use did not work. In Paper UI everything is working just fine.

I appreciate your help and time.
Actually I just need to get the HABpanel working on 2.5. This should do it.
May I will just now and then install a newer version and see if it is working.