ESP_Easy MQTT BInding OP2

Hi, i have problem with configuration ESP_Easy MQTT and openHAB2
Why is not working? What is wrong?

My ESP config is:

Service config is:

Broker config is:

Broker status is:

Generic MQTT is:

You did not setup a StateTopic for the Number Channel of your Generic MQTT Thing, without that it will not subscribe to any message. Depending on the content of this message sent from your device you might need a TransformationPattern as well.
Finally you need to create an item which subscribes to that channel in order to present that item on an UI.
[Edit] It seems you have an item linked already (named “Generic MQTT Thing_1_MyRoom”).

I’m link item. Is not the same?

sorry, but I did miss that item in the original reply. See the [Edit]

However, the main problem is/was that you did not setup the “StateTopic”.

ok, but what i need to put

Into this field you need to put the MQTT Topic of the message that holds the information you want to show with your channel.You should know it from setting up your ESP device!

Using an external MQTT viewer like MQTTfx you can subscribe to all messages and listen until you find the required one.