ESP8266 + RS232 + Epson binding

Discovering the epson projectors binding gave me the understanding i can do a lot more through RS232 port than the irda. So currently looking for a solution if ESP8266 can be connected to the RS232 port on the projector so it can be binded to openhab. Is there a way to do this?

So no help here? Ok let’s skip the esp8266 part. Maybe some ready made plug n play controllers not costing a fortune?

Epson projector binding already support direct serial port communication to projector, but also TCP communication, which make possible to use also cheap serial port / TCP converters (wireless or wired).


As communication between projector and binding is not very time critical, you can add any kind of device between openhab and projector (only your imagination is the limit), as long the device somehow offers serial port (real or virtual) )or tcp server functionality where binding can can connect.


I had asked about ethernet but just realized the projector itself didn’t have Ethernet. Anyways, I’m building out a theater right now and soon need to decide what type of cables to pull to the projector (other than power and HDMI). Would you go with just a serial to my component cabinet and either convert to ethernet. The binding info page says “serial port on the host system where projector is connected”. Does that mean that I can have the projector connected to some other computer other than the one running openhab, or am I reading too much into it? Thanks for the help, sorry for my ignorance, just starting to get into openhab, love what I see, just a ton to learn.

Hello Michael,

regarding your cable requirements:
Always pull one or two network cable to a projector, even if you do not need it right now.
Your next setup may support streaming media directly to the projector so you are prepared.
In addition I´d pull cable (5 wires) for 2-3 power plugs - you may want to switch then separately.
Think about e.g. a small media player or a Raspberry that you want to connect…
HDMI is fine, but stay flexible by making ethernet and HDMI replaceable. One never knowns which
cable is required by upcoming standards.

I have mounted the beamer on the living room ceiling, added a POE-powered serial/TCP adapter plus on Pi and things are running fine. HDMI is a pain even with proper cables, but having wireless support in the Epson even 3D is working without cable so I don´t spend time to investigate further… maybe the AV receiver´s sync is failing.

Your question on the connection to a separate computer:
The beamer may be connected to another PC (or PI or Serial/TCP adapter) - if it provided a corresponding serial port over TCP to the network a remote machine with e.g. openHAB running is able to connect.


Would like to add that consider CAT7 for this use case.
As we are going for the higher resolution 4k the bandwidth will be highly required for streaming.

Hopefully future pulls of cable won’t be much of an issue. The ceiling of the basement will be sheetrock but in between the utility / computer closet and the cabinet off of my theater will be a very clear path in the ceiling tray. From the cabinet to the projector will be short and the same circumstance. My first plan was to run conduit between everything and leave pull strings but it seems a little overkill. I am not messing with cat5 since i have most of a 1000 foot roll of cat6.

Back to the ESP8266, it is TTL level RS232, you need to pump it through a Max232 to avoid blowing the chip.
Home threater stuff, just get a Wifi Serial Port. Global Cache is a good brand, or many generics on eBay, you will need some software that runs on the server to convert the TCP connection back to a (virtual) COM port.

Global Cache makes lots of good things for Ir, Serial, On/Off, video sensing, etc…

The ESP8266 is truly an awesome chip, but it is 3.3v, needs power filtering, resistors on GPIOs…
It is by its nature a wireless UART isn’t it? But does so much more.
I use them as Wifi on/off switches. You’d get more support from the forums.

Anyway, Global Cache has what you want if you have the bank account for it.

I got a USR-TCP232-200 Serial RS232 to Ethernet TCP IP Converter off of ebay. I have it set up currently as a TCP server and have the driver for it running it on my current openhab box to create the virtual Serial port. Plugged the port I set into the config file and it all works. This is great for now, but I have been considering moving over to a PI at some point. In attempt to get this ready I changed the config for the device over to TCP client, set an IP on it and plugged that ip into the host part of the config. This didn’t seem to work. Is this how it "should’ be done? Any pointers on how to configure openhab as well as the adapter so that I can send signals to the projector?

Not sure if you are talking to me and I don’t totally follow what you are saying. But I think, from what I can understand, you need to leave the USR Serial Port in Server mode. It probably supports multiple clients connecting to it…

Good luck.

Anyone know how i can change rs232 codes to use in an asus projector?

Could anyone please give me a nudge in the right direction.

I get everything looking like it is working correctly but the projector doesn’t respond.

I have Openhab2.2 on Raspberry Pi3 (have tried it on Windows, but didn’t get anywhere), I have little / no Linux experience, but have gone through the tutorials etc and this is what I have got so far.

My setup is RaspberryPi3 - OH2.2 - Epson X27 - USB to serial adaptor with serial cable.
openhab and tty is in dialout.
crw-rw-rw- 1 root dialout 188, 0 May 3 11:17 /dev/ttyUSB0
The user openhab’ is already a member ofdialout’.



sitemap projector label=“Projector”
Frame label=“Projector Controls” {
Switch item=epsonPower label=“Power”
Text item=epsonSource
Selection item=epsonDirectSource label=“DirectSource” mappings=[20="C$
Switch item=epsonMute label=“Mute”



Switch epsonPower { epsonprojector="projector:Power:60$
String epsonSource “Source [%s]” { epsonprojector="projector:Source:O$
Number epsonDirectSource “Direct Source” { epsonprojector="projector:DirectSo$
Switch epsonMute { epsonprojector=“projector:Mute:ON,60000” }

I have checked the port is /dev/ttyUSB0


2018-05-03 11:49:00.035 [ome.event.ItemCommandEvent] - Item ‘epsonPower’ received command OFF

2018-05-03 11:49:00.053 [vent.ItemStateChangedEvent] - epsonPower changed from ON to OFF

2018-05-03 11:49:03.961 [ome.event.ItemCommandEvent] - Item ‘epsonPower’ received command ON

2018-05-03 11:49:03.974 [vent.ItemStateChangedEvent] - epsonPower changed from OFF to ON

==> /var/log/openhab2/openhab.log <==

2018-05-03 11:50:04.355 [INFO ] [el.core.internal.ModelRepositoryImpl] - Refreshing model ‘projector.sitemap’

2018-05-03 11:50:04.439 [INFO ] [el.core.internal.ModelRepositoryImpl] - Refreshing model ‘projector.sitemap’

==> /var/log/openhab2/events.log <==

2018-05-03 11:50:12.981 [ome.event.ItemCommandEvent] - Item ‘epsonPower’ received command OFF

2018-05-03 11:50:12.998 [vent.ItemStateChangedEvent] - epsonPower changed from ON to OFF

2018-05-03 11:50:14.072 [ome.event.ItemCommandEvent] - Item ‘epsonPower’ received command ON

2018-05-03 11:50:14.082 [vent.ItemStateChangedEvent] - epsonPower changed from OFF to ON

Please help.

I actually do not know how I did it but I now have the Epson working. I had changed pretty much everything to do with the binding, didn’t get anywhere apart from it not working.
I uninstalled openhab2 and reinstalled.
Started from scratch, couldn’t see USB0 put it in the dialout group.
Then it just worked.
Really love the Habpanel