ESXi 6.7 U1, Openhab 2 and ZWave stick

  • Platform information:
    • Hardware: Intel NUC i5
    • OS: Debian 9
    • Java Runtime Environment: 1.8.0_191-b12
    • openHAB version: 2.4.0-SNAPSHOT Build #1433
    • ESXi version: 6.7.0 Update 1 (Build 10764712)

Hi Community,

I am playing around and try to move my OH installation to an ESXi VM. So far so good, OH is running fine. But not all of my USB devices are working.

For example my Z-Stick S2 is detected but not initialized by the zwave binding. I disabled vmkusb driver but with no luck.

That’s the (short) log:

2018-11-21 21:16:50.306 [DEBUG] [g.openhab.binding.zwave.handler.ZWaveSerialHandler] - Initializing ZWave serial controller.
2018-11-21 21:16:50.306 [DEBUG] [enhab.binding.zwave.handler.ZWaveControllerHandler] - Initializing ZWave Controller zwave:serial_zstick:0001.
2018-11-21 21:16:50.306 [DEBUG] [enhab.binding.zwave.handler.ZWaveControllerHandler] - No network key set by user - using secure random value.
2018-11-21 21:17:37.366 [INFO ] [g.openhab.binding.zwave.handler.ZWaveSerialHandler] - Stopped ZWave serial handler

But the same stick is working with the open zwave control panel, with and without vmkusb driver enabled.

Funny thing is that the stick lost its network key …

Other sticks like my bluetooth long range stick are working out of the box.

I have read some threads here and on other sites from people having (almost) the same problem. But if I got it right it always boils down to disable the vmkusb driver. Which obviously does not help in my case.

Any ideas from the ESXi folks here (apart from the socat and usbip solution)?



Unfortunately I don’t have any suggestions. I started on ESXi 6.5 and I had to disable vmkusb to make it work reliably. But I’ve since upgraded to 6.7 U1 and it has been working great. I don’t know if my disabling of the vmkusb driver stuck through the upgrade or not. I just know that it’s been working great since the upgrade. Good luck!

Hi Rich,

Thanks for your answer. I tried it with a fresh 6.5 install and vmkusb disabled. Same situation. I guess it must be the hardware of the NUC…

I wouldn’t blame the NUC just jet.
Here, Openhab is running on a i5 NUC(NUC7i5BNK), on a CentosVM.
KVM hypervisor (proxmox)
No issues with NUC hardware, or any virtualized hardware.

Not directly a solution to your issue, but the fault is not necessarily in the NUC hardware.

True, I might have given KVM a try instead of ESXi :wink:

Problem solved. I ran into this:

If I enter a security key in the binding configuration the stick initializes immediately (despite the fact that I don’t have security enabled devices).

My old system runs with an older binding version so I was not aware of this when installed my VM with the latest snapshot. Coincident… :wink: