Eth0 no inet openhabian / rpi

I’m running a RPi4 with openhabian and OH 3.1.0M2 (and docker wit a container running Unify controller, OH is NOT running in docker).

I installed pigpio ( trying to get IO running). I’m not sure if it’s related but after trying to get it to work my network is not connecting.

I connected a screen + keyboard and made the two pics from the screen after logging in as ‘openhabian’ and after ifconfig -a. It s ems like my eth0 is not getting an IP.
The is the fixed ip address I used to have ( assigned via dhcp, fixed on my router based on Mac address).

Any ideas what I screwed up?

You installed Docker on top of openHABian ?
Duh. That’s not supported. Docker easily screws up networking and mounts/environment settings if you don’t pay a lot of attention which is probably what happened here. Why did you do that ?
It means noone tested that combo so anything can happen (as you saw …) and noone really can/want to help you because your setup is different from anyone else’s running (plain) openHABian.

In the past (OH2) I wanted to run OH on the same rpi as a Unify controller and TasmotaAdmin. Due to some issues with ports I solved it with docker.
Is has been working perfectly both with my old OH2 and new OH3 on openhabian. But today was not my lucky day and I screwed it up.
I guess it will be quicker to download openhabian again and start over again. That’s probably much quicker as trying to solve something I don’t understand.

Would the openhab-cli backup option be the best to use?
I think the Amanda back up might have the issue in the backbup

Ok, short update. I flashed a new sd with openhabian but still no ethernet connection. Could be that my ethernet port is physically broken. I’m installing openhabian now with the (brilliant) wifi-hotspot functionality.
I’ll keep you all posted