Eurotronics Spirit - lost Protection (Child-safe) Setting

OH 2.5.5, snapshot 109.

Until recently I didn’t use the .items file, so my Spirit heating regulator’s items had been auto-created.

In PaperUI, the Spirit had the setting (Popup) to set the child-safe mode (knobs on the device are deactivated then).

Then I described all my devices in an .items file, and deleted all auto-created items in one go.
In the progress of creating the .items file I must have overseen the channel that is responsible for the child-safe mode (I believe it’s called “Protection”, from what I see in the binding’s XML file).

So my idea was to delete the thing (not exclude) in PaperUI, activate auto-linking, and re-add it. That worked, but still I don’t have the child-safe setting in PaperUI.

So I out-commented my own items for the node in the .items file, and tried again, but now the inbox remains empty, the device is not found.
Restart OH.
No luck.
I removed the device from the heater, and as the device is in child-safe mode, I removed batteries, to enable button functionalty (to wake-up the device).
The device show then Ins (Installation). I fooled it by pressing my finger into it while it moved…
Now child-safe mode is (in the device) still active. :grimacing:

Whaa, in the log:

2020-05-08 10:00:37.709 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 16: Device discovery resolved to thingType zwave:eurotronic_spirit_00_000
2020-05-08 10:00:37.709 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 17: Device discovery completed
2020-05-08 10:00:37.710 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 17: Device discovery resolved to thingType zwave:eurotronic_spirit_00_000
2020-05-08 10:00:37.711 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 18: Device discovery completed
2020-05-08 10:00:37.712 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 18: Device discovery resolved to thingType zwave:eurotronic_spirit_00_000
2020-05-08 10:00:37.713 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 20: Device discovery completed

So the device (it’s Node 17) has NOT been removed, thanks PaperUI (for so many things…)

Back on track, re-added the device.
No luck. All I get is this:

And so this in the GUI, no child-safe mode:

Removed the device.
Updated OH 2.5.5 to snapshot #111.
Same difference, no child-lock setting.

So I started an older backup (OH 2.5.4 release version), and there it is - this is how it should look like (“Local Device Protection”):

So I looked at the channels, still nothing visible what the Protection manages:

??? :thinking:

This seems to be handled by the binding in some special way?

I inspected the XML file in the zwave folder, and found that the working one has this entry, sound like it could be the child-safe mode (there are also other differences in it):


I have no idea if it’s a good idea, but I put this XML file into my non-working setup (no auto-created items).
Doesn’t work.
I put it into the OH directory where the items have been auto-created:
No luck.
Delete the device, the node 17 xml file is still there.
Re-adding it from the Inbox.
Same result.

So it seems to be hardcoded in the binding of 2.5.4 release, while 2.5.5 snapshots don’t have it?
On the other hand I believe that it was also working in 2.5.5 #109, and it went away after creating my items via .items file.

Local Device protection is listed as a channel in our database here

Please follow tine binding nstructions for when things do not go as planned. I recommend restarting the binding and posting the unfiltered debug log here.

Thank you Bruce, it was an easy one - solution: Eurotronics Spirit Value Controller Z-Wave plus Disable Buttons

1 Like