Everspring Zwave AN158 not reporting watts - can not set association group 1

Tags: #<Tag:0x00007f7465ead450>

Hello All,

I have just acquired an Everspring AN158 on/off module with power metering and am trying to get it to report watts usage, it’s reporting KWh fine.

As I understand I need to set association group 1 to the controller which I can do in PaperUI fine and in the logs it reports

019-11-03 23:57:55.869 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:512:node16' has been updated.

2019-11-03 23:57:55.890 [vent.ConfigStatusInfoEvent] - ConfigStatusInfo [configStatusMessages=[ConfigStatusMessage [parameterName=group_1, type=PENDING, messageKey=null, arguments=null, message=null, statusCode=null], ConfigStatusMessage [parameterName=group_2, type=PENDING, messageKey=null, arguments=null, message=null, statusCode=null]]] 

But, I still don’t get any watts reported.

And, if I reboot my RPi (I’m running openhabian 2.5.0M4) and query the association it is not setup again so I don’t believe the GUI change is actually changing the device association (I presume the association is read from the device during initialisation/boot?)

Any ideas please?

I collected some logs here:

Thanks!

No, the binding already sets that.

What is the setting for configuration parameter 3? If set to 0 that disables the meter reporting.

Correct. The log you quoted clearly shows the command as PENDING

Edited logs are useless for troubleshooting purposes

The log viewer can help you interpret full debug logs…

https://www.cd-jackson.com/index.php/openhab/zwave-log-viewer

Parameter 3 defaulted to 30 seconds, I also tried 60 no change.

But you advise I shouldn’t need to do this anyway as the binding should configure association group 1, I did not know that. Must have missed it in the docs.

I can capture further logs but nothing else useful is reported after what I posted as far as I could see. Unless you need something before the change.

Thanks.

Might find this thread useful background information. Note there is more than one GUI, each with quirks.

Duh, add missing link

Link missing?

1 Like

Thanks I had already seen that.

So, to proceed further shall I attach logs from bootup until when? 5 minutes after I request association change? It’s mains powered device so I would expect it to process commands very quickly.

You can enable debug logging and then restart the binding from the Karaf console., perform whatever tests you wish and use the log starting at binding startup. Some people direct the zwave logs to a different file as directed in the official documentation.

Here is a full log, seems to report 0 watts every 5 mins ?

Really don’t understand as there is a load connected and either way it should report every 30 secs…

Looks like it is reporting to me.

It’s node 16 I have an issue with.

Perhaps you missed it?

No, as I said in my first post kwh works fine it’s just watts.

Also what you pasted implies the controller polled the device, I am expecting every 30 seconds for the device to transmit to the controller the watts - not relying on polling.

Anyone have any further ideas please?

It looks like it is reporting fine to me -:

It’s only reporting every 5 minutes, but clearly the association group is configured just fine (and that can also be seen in the log) -;

1 Like

Thanks for your input.

OK, so it appears to be working, guess my module is faulty then as there is definitely a load on it yet it reports 0 watts :cry: