Everyspring AN158 not reporting meter watt change unless resetting


My home automation has been off about 2 years now. I used to run on a Vera3 but their upgrades should more be called regressions so I decided to look into OH2 again and wow, this project rocks now!

I am now trying to set rules to have the same behavior I used to have and I am hitting an issue.

I am using 2x Metered Wallplug from Everspring: AN158-2. I use them to monitor the wattage of machines (wash machine, etc…) in order to know and take actions once those machines’ cycles are finished.

I used to work kinda ok with my Vera3 (although the difference between working and not working was kinda black magic…) but it does not seem to work with my current config.

The issue is not about the rule. For now the issue is that the device does not seem to report the meter watt unless I :

  • trigger meter_reset
  • toggle the switch
  • run a heal/reset of the device

I have been fiddling around and my current params are:

My understanding is that:

  • true period is a value in seconds. The watt value is only reported if the value has been stable for the last N seconds. Since the wattage varies a lot, I set it to 0.
  • Meter report period: I am assuming this is seconds but not getting values, I set it to 1
  • send out basic command sounds like better enabled…

Feel free to correct me if I miss-understood a param. Maybe someone with a working config could share his settings?
For the test, my wall plug is 1m away from the zwave controller and I am using a heat gun so I can easily and quickly control how the wattage changes.

There’s an association group to set in the device somewhere, so that it knows who to report to.

1 Like

Hi @rossko57, thank you for answering my question so quick with a hint.
This is interesting, I did not think about that.
Does not a Thing always report by default to THE controller when no association is set?
I have now anyway something I can test, thank you :handshake:

@rossko57 many thanks. For what I can see, you solved my problem!
I went from:


And the updates show up!