Evohome binding 2.0

oh2bindings
evohome
honeywell
Tags: #<Tag:0x00007f014b6e7898> #<Tag:0x00007f014b6e76e0> #<Tag:0x00007f014b6e7528>

(jvanzuijlen) #61

Yup, changing your password reinitializes the connection to Honeywell. That works equally well :blush: I got a little bit closer to installing Eclipse so a fix is on the way…


(jvanzuijlen) #62

So I got my Eclipse back up and looked into the communication issue. I at least know, and already fixed, the cause of the updates stopping. I’m looking into other network availability related vulnerabilities as well. After that I’ll fix the issues on the PR and post a new alpha release.


(Nick Wootton) #63

:+1:


(arnold) #64

Maybe a stupid question, but i can’t manage to change the setpoint value.
All the data is displayed. but i’m not able to control the temperatuur.

What could be wrong with my thing’s file.
or more better, what thing line do i use to controll the setpoint :slight_smile:


(arnold) #65

i get it, in my first try i used the wrong item name, so nothing was happening.

this is in my sitemap
Setpoint item=SetOverLiving step=0.5 minValue=15 maxValue=25

and this in my items
Number SetOverLiving “Living Over [%.1f °C]” (grHeat) { channel=“evohome:heatingzone:Evohom:xxxxxx:PermanentSetPoint” }


(Crispin) #66

Change the override option. Setpoint is readonly


(jvanzuijlen) #67

I see you figured it out already :grin: Regardless I updated the TS with a link to some documentation, including some examples. Hope it helps with future issues.


(jvanzuijlen) #68

By the way, I looked into the postUpdate vs sendCommand differences.

What happens is this: when you use postUpdate, only the value of the item is updated, but the “command” (which it really isn’t) never reaches the binding. This results in an updated value in the UI up onto the point where the next evohome update is recieved and it is set to the actual value again.

Using sendCommand the value in the UI is updated AND the command is send to the binding, which, in turn, forwards it to your evohome. If that was successful, the next evohome update which ,of course, reflect that change.

I think this is due to openHAB and it is by design. This way you can update UI values without triggering any rules or bindings. I’ve used it to update the value of an item from within a rule where that rules was triggered by that same item. Works flawlessly.

See also: sendCommand vs postUpdate, https://stackoverflow.com/questions/28981946/what-is-the-difference-between-postupdate-and-sendcommand-in-openhab


(jvanzuijlen) #69

There. I just fixed the last remark on the PR. I’ll see if I can update that tomorrow as well as creating a new release. I’ll probably have to fix some things to close the PR but I feel the end is nigh.

For now, have a nice evening!


(¯\_(ツ)_/¯) #70

good job, cant wait to test the new release!
Have a nice evening!


(jvanzuijlen) #71

I ran into a little delay due to some linting issues, but here it is:

Get it while it’s hot!

The PR is now being examined by kai, so I expect that it will be merged soon. Please join me in testing the binding to make sure it does what it needs to do :-). The update and authentication issues should be solved as well, so I hope you can run without hiccups now.


(¯\_(ツ)_/¯) #72

Nice! Will definitly test it after this weekend, maybe sunday evening if i got time for it.


(jvanzuijlen) #73

Hi guys, unfortunately my binding still crashed after a couple of days…
I added a more robust safeguard to the update mechanism which should definitevely solve it.


(jvanzuijlen) #74

And it still stops updating. Seems like the changes needed to get it merged didn’t really contribute to its stability. I’ll update here when it runs successfully for a week at my end.


(¯\_(ツ)_/¯) #75

Can’t we make an exec binding which restarts it through karaf or something for the time being?


(jvanzuijlen) #76

Sure, a cronjob should work as well. I posted something similar in the trådfri topic a while back.

Anyway, I’m not blocking the PR by it and try to fix it in the meantime. Feels like a trivial thing, but I’m not sure what the issue is right now. It seems to only occur after a couple of days, so preproducing and validating is slow.

Edit: Link to the cronjob solution IKEA Trådfri Gateway

Come to think of it; an exec binding should be able to do the same. I’ll check if I can make it work.


(¯\_(ツ)_/¯) #77

That should work as exec i think, gonna try this when i get home.


(jvanzuijlen) #78

@Mickroz any luck with the exec binding?

I got a little bit further with testing. Turns out the binding doesn’t crash anymore; it just sometimes seem to wait indefinitely

2018-05-15 10:03:20.077 [DEBUG] [nding.evohome.internal.api.ApiAccess] - Requesting: [https://tccna.honeywell.com/WebAPI/emea/api/v1/location/xxxxxx/status?includeTemperatureControlSystems=True]
2018-05-15 10:03:20.274 [DEBUG] [nding.evohome.internal.api.ApiAccess] - Response: HttpContentResponse[HTTP/1.1 200 OK - 1799 bytes]
2018-05-15 10:03:20.286 [DEBUG] [nding.evohome.internal.api.ApiAccess] - Requesting: [https://tccna.honeywell.com/WebAPI/emea/api/v1/location/xxxxxx/status?includeTemperatureControlSystems=True]
2018-05-15 10:03:20.503 [DEBUG] [nding.evohome.internal.api.ApiAccess] - Response: HttpContentResponse[HTTP/1.1 200 OK - 6236 bytes]
2018-05-15 10:03:20.515 [DEBUG] [nding.evohome.internal.api.ApiAccess] - Requesting: [https://tccna.honeywell.com/WebAPI/emea/api/v1/location/xxxxxx/status?includeTemperatureControlSystems=True]
2018-05-15 10:03:20.728 [DEBUG] [nding.evohome.internal.api.ApiAccess] - Response: HttpContentResponse[HTTP/1.1 200 OK - 1376 bytes]
2018-05-15 10:03:35.759 [DEBUG] [nding.evohome.internal.api.ApiAccess] - Requesting: [https://tccna.honeywell.com/WebAPI/emea/api/v1/location/xxxxxx/status?includeTemperatureControlSystems=True]

That response never comes thus halting the update loop, ultimately letting the access token go stale. According to the docs of jetty this is expected behavior since the timeout of a request is bound to system settings. My system is, apparently, configured to never timeout.

I fixed this in my development system and has been running for three workdays days now. In between days, my computer goes into sleep mode, resuming the morning after; the binding still running smoothly.

In the meantime kai has reviewed my code as well - some minor remarks as a result. I’ll pick these up with the next release, which will include my fixes for a fixed timeout. I think that’ll be the last step before it will be merged. Please help me test the next release thoroughly so we will have a stable, well performing binding in the 2.3.0 release!


(¯\_(ツ)_/¯) #79

Yes, just had to install sshpass on my system, but it works with the exec binding:

sshpass -p habopen ssh -p 8101 openhab@localhost "bundle:restart 'Evohome Binding'"

According to my graph, i don’t see any timeouts.


(Tim Welch) #80

Can anyone assist? While I realise this is alpha software it seems that others have it working happily.

I’ve installed the binding as an addon and I can get the Evo Home account online

evohome:account:evo_home' changed from INITIALIZING to ONLINE

but I cannot get the display or any zones to come online and get the following error

'evohome:display:evo_home:display' changed from INITIALIZING to OFFLINE (COMMUNICATION_ERROR): Status not found, check the display id

The display id I got from my display by holding down the Display Settings button - is this correct?
How do I get the ID’s for the individual heating zones?

Would it make any difference that I am in New Zealand and use https://international.mytotalconnectcomfort.com ?

Any assistance would be greatly appreciated as I’ve been around and around in many circles.

Cheers,
Tim Welch