Evohome binding 2.0

Tags: #<Tag:0x00007f0147c75f98> #<Tag:0x00007f0147c75de0> #<Tag:0x00007f0147c75c00>

(¯\_(ツ)_/¯) #101

Np :wink:

(Christopher Smith) #102

Hi, I manually downloaded the add-on and tried to create a Account with the Paper UI

It initially reports as “Initializing” and finally reports
Status: OFFLINE - COMMUNICATION_ERROR Authentication failed

I put in the email that i use to log in to the web site as the user and the password for my TCC account.

It works on the Web login page.

Any ideas or suggestions?

(Michael Cumming) #103

Currently, the binding is limited to devices registered in certain locations - currently devices registered in the US/Canada do not work. You could try unregistering you device and adding it to the UK site but this will break the mobile apps. And the UK mobile app is not available if you are in the US.

(Christopher Smith) #104

My thermostat is not a very advanced model, a basic WiFi model. It does work with the TCC web site and and USA App.
Is the TCC API also limited to specific Honeywell thermostat models?

(jvanzuijlen) #105

Yeah, it’s ‘limited’ to these countries:

Belgique - Français Česká Republika - Český Danmark - Dansk Deutschland - Deutsch España - Español France - Français Ireland - English Italia - Italiano Latvija - Latviešu Lietuva - Lietuvių Magyarország - Magyar Nederland - Nederlands Norge - Norsk Österreich - Deutsch Polska - Polski Portugal - Português România - Română Schweiz - Deutsch Slovensko - Slovenský Suisse - Français Svizzera - Italiano Türkiye - Türkçe United Kingdom - English България - Български Україна - Український

I didn’t know that app isn’t available in the US.

One alternative route you could try is to share your installation with a UK account, if that’s at all possible.

(Christopher Smith) #106

It boggles my mind that TCC would have different API’s in the Europe and North America
I bet there is an another server instance for North America.

(jvanzuijlen) #107

I don’t know really, I haven’t tested it out like that. Maybe I’ll try to add support for that in the future, but for now my focus is to get it merged into the main line, with stable performance and the features. That proves to be enough challenge since that PR gas been open for a year now… If you’d like to help me out, check if it does work with the python evohome client. Changing the urls to the US ones of course.

Edit: link to the python client (https://github.com/watchforstock/evohome-client)

(Michael Cumming) #108

I am guessing the APIs are the same - I did try and register my device in the UK but it would let me since it is registered on the US server. The only reason I haven’t unregistered from the US server is it would break the family iPhone apps - and you cannot download the UK version of the app in the US… Frustrating :frowning:

(jvanzuijlen) #109

I see that it is solved in Home Assistant actually: (https://github.com/home-assistant/home-assistant/blob/master/homeassistant/components/climate/honeywell.py) with a region selector. I won’t take it in for this PR but I could make it the first thing on my list after.

In other words: there is hope, but please bear with my while I try to get something merged first :slight_smile:

(Michael Cumming) #110

I just saw that :slight_smile:

Thank you for taking the time to solve this!

(Pop Eating) #111

Did someone else noticed that sensor / Heating zone goes offline if the battery is low?

i got this:

Status: OFFLINE - COMMUNICATION_ERROR TempZoneSensorLowBattery

in my things details on paperUI

the fact is that the sensor got two battery dots as some of the others sensor i have that are online
the fail sensor is online on the legacy system (app and wall appliance)
tried to reboot and rescan things too

just for more details, the TempZoneSensorLowBattery is on a sensor that is coupled with another one (both sensor with 2 battery dots) so i dont really know which of the twos can be the problem of the battery.

any suggestions besides changing batteries (which looks a bit of waste, since these sensors have not so low power and other sensors in same conditions communicate well)

thank you

(Opsym) #112

I have a Honeywell Round Modulation. This thermostat has a single zone. I can also use the Honeywell app to read the status and set a schedule.
I tried the evohome binding and reading the status seems to work fine. However, setting the permanent setpoint override and cancel override does not seem to work. They also do not appear as channels in the paper UI.

When I click on the Cancel button I see the following lines in the log, but no communication with the evohome server.

22:00:03.846 [INFO ] [smarthome.event.ItemCommandEvent ] - Item ‘_SetPointCancel’ received command ON
22:00:03.849 [INFO ] [smarthome.event.ItemStateChangedEvent] - _SetPointCancel changed from OFF to ON

I do not see errors in the log.
Have others tried the evohome binding with the Round Modulation? Should it work?

I know the evohome interface provides more values (e.g. outside temperature). Does the binding also provide these values?

I am running openhab 2.3, evohome binding 2.1.1? (just installed it).

I just saw that binding 2.1.1 does not support cancel.
I updated the binding to 2.2.0 and now the binding does not work at all anymore :frowning:
When I enter the username/password I get an error 500.

(Michael Cumming) #113


Checking back to see if you have had a chance to merge the changes so that we use the region selector?


(jvanzuijlen) #114

500 sounds like a server error. Are you in one of the aforementioned regions?

(jvanzuijlen) #115

Hi Mike, I just finished another review iteration for the initial release. I want to get that in first; it has been in review for over a year now. I don’t want to add new features before that is accepted. I created an issue on github so it stays on my radar.

(Opsym) #116

I am in Europe.

My explanation of what it going might not be complete. I get the 500 error in the Paper user interface when I configure my Evohome account. I might an issue not related to the binding itself. I checked the file settings on the server but cannot find any issues. Any ideas what could be wrong?

(Michael Cumming) #117

Thank you for the update.


(jvanzuijlen) #118

Honestly, no. Could you perhaps post a screen shot?

(Opsym) #119

This is what I see after I press the Blue checkmark

(jvanzuijlen) #120

Seems like a 500 from the server. Another question: can you reach your device via this app?https://play.google.com/store/apps/details?id=com.honeywell.totalconnectcomforteurope