Ewelink / Sonoff Binding - New binding without flashing

If it uses the standard api install the binding and scan for devices, it will create a cache file which you can dm me and I’ll take a look for you

It is happening all the time even when not trying to issue any command.
Also, if the binding is set to work only locally, why does it need a response from the servers.

Few questions:
Are you using text files or ui to create things?
Have you restarted your openhab instance since changing to local only?
What type of device does the retry relate to?

Sonoff thing created through the ui.
Correct, OH was restarted multiple times when binding configured as local only. It has been local since installed jar file (using 3.4 R1). The retries existed also in 3.2 R12.
I have only 2 devices, 1 channel relay: SONOFF S26R1 and coolkit 0186
How do I identify to which device it reports a retry?

I can’t seem to figure out how to load this binding into Openhab3. I tried adding it to the Addon folder on my raspberry pi. It crashed the pi. Any ideas on what I am doing wrong? Can you try to submit this binding to the official addon library with Openhab?


I just got a new toy - Sonoff TH Elite - or better say THR320D - which basically is identical to a TH16 but it has a LED-Display:

I was wondering if it could be easily added to the binding?

1 Like

Hi @delid4ve, first of all, thanks for your great and consequent work on it.

What is the status of the implementation of DUALR3?

My issue: DUALR3 can be discovered without any problem, however I suppose, not all potentially possible channels are imported, only following:

I use my DUALR3 in motor mode and when I just trigger Switch 0 or 1 nothing happens :thinking:

I use that one → org.openhab.binding.sonoff-3.4.0-SNAPSHOT_R1.jar

I guess, depending on the mode set, you need different commands to trigger the outputs, e.g. “do”:{“motorTurn”:1}}, like on that extraction from log:

Can you send me the cache file created in motor mode under userdata/sonoff. As soon as i have this off someone ill get added.

How do i get this?

Hi there,
Thanks in advance for the great binding.
I have been using it with number of Sonoff things and all worked fine.
Just brought some new Sonoff MINI trying to install into some ceiling light, the MINI add fine in the ewelink app and works fine through the app.
But when I try to add them in openhab, I got the folowing error:

2022-10-11 16:44:32.236 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing ‘sonoff:1:fa7361ac9a:bdc8339e6e’ changed from INITIALIZING to OFFLINE (CONFIGURATION_ERROR): This device has not been initilized, please run discovery

I have other MINI in the same network which still work fine under Openhab, just the newly brought ones can’t work.
I have also try scan new device and the new MINI can’t be discovered.
Anyone have any idea what happen?


btw, I’m running sonoff binding version as follow:

openhab> bundle:list -s | grep -i sonoff
236 │ Active │ 80 │ │ org.openhab.binding.sonoff


Just discovered that after install the latest version of binding, everything work fine!!
Sorry for the stupidity and thanks a lot !!

Patrick :slight_smile:

Hi @delid4ve,
I have a problem with my SONOFF 4CHR3 on openHAB 3.4.0.M3 + binding.sonoff-3.4.0-SNAPSHOT_R1, it’s strange
I can’t add a link to item

In log:
Received HTTP PUT request at ‘items/4CHPROR3_Switch0’ with an invalid item name ‘4CHPROR3_Switch0’

What do you think could be the problem?


Dear All, Any news related sonoff binding upgrades? Are you still working on it? How can we get NSPannel working? At least the basic funcions (2 switches and get temperature)?

Hi @delid4ve .
Again thanking you for the work done, still no news for the DualR3 as a controller for the rollershutters?

Hi Dave, do you still need this, I should be able to send you one.

Hi @delid4ve, thank you so much for all the effort and dedication to build this solution, I really apreciate it!

Just one question, when I try to configure the Sonoff Account thing I always get the error message saying the Cloud is Offline, do you know why this happens? If I configured just Only Mode, then go Online but the discovery didn’t find any of my devices.

Hello everyone. Can anyone explain the procedure to download and install the binding? Thank you so much for your help whoever that may be.

Hi. Can enyone tell me how to add this binding? I cannot find any tutorial explaining how to add it to the existing list. It is not showing up in the UI. Thank you.