Ewelink / Sonoff Binding - New binding without flashing

Hi,

for me changing the name of the *.jar does not solve the discovery problem… stil not possible to look for new devices!
Can you check, if the discovery is for you available?
Thanks
Cheers
Stef

The 4.0.0 in my openhab 3.4.4 works without needing to be renamed. The auto discovery has never worked for me, but I also only have a Dual R3 Lite which is not listed in the binding (using the standard Dual R3).
I am running openhab on a Qnap NAS and all is working fine on OH 3.4.4. Unfortunately, as I stated above, cannot get the Sonoff binding to work on OH 4 or 4.0.1. If someone has any suggestion, would love to try it.

For multicast across subnets use mdns-repeater. it works nicely for this binding. tried on openhab 3.4.5.
on the openhab box, run for example

mdns-repeater lo wg0

wg0 is the tunnel interface connecting the two subnets. same thing on the other side.

Hello!

I have the latest of openhab and try to add the latest sonoff binding (org.openhab.binding.sonoff-4.1.0-SNAPSHOT.jar), but noting happens, after is put it in the addons map, and give openhab priv to the file, and for sure i run the openhabin-config for fixing premissions. Start/stop service, clear cache.
In openhab-logs i don’t get any error, or clue why it does not show up in bindings.

Is there any reason or any known issue why it does not work?

Thx any for advice.

From what others are saying on this thread, the binding for openhab 4 doesnt do discovery but if you have the thing already defined (as part of OH3) then it will stay if you upgraded to OH4.

So to get it work i have to downgrade to oh3? Ok i give it a try. Thank you @candiesdoodle !

If you have the device ID you could try the textual configuration to add the account thing and the device thing. Format for the configuration is given in the GitHub page. I just did that last night without rolling back to OH3

If I understand correctly you do not see the binding when trying to add a Sonoff device. Am I correct? Because if I am, then @roher and I have the same issue as yours.

1 Like

My problem was, that the binding didn’t show up, so i colud not do annything.After is downgraded to OH3 i got the bindings, but it does not connceting to the cloud so i got a step forward and two step back :confused: I try to flash the sonoff thing i have with tasmota.

So exactly the same issue. The binding does not show up, while no problem using the 4.0 version with 3.4.4.
Seeing that people are having issues with the latest openhab version and no solution to the Sonoff binding yet I am staying with 3.4.4. Hope issues get solved.

I am on OH 3.4.3, I confirm the above workaround fixed my issue (been up and updating for the last 4 days).

Cheers,
Espresso

exactly the same issue cannot add new devices(binding doesnt show) and get the same error when trying to add from dev bar

Just tried jgesser fork in OH4, but all my devices including mini, S26 cannot go online in local mode.
Things report something like device not support in local mode, but everything work smoothly in local mode in OH 3.

Tried to upgrade to 4.1.0M1 and everything went smooth. Only thing not working is the Sonoff binding which is not showing up in the binding list. Is there a way to get it back?

I’m using this version with Openhab 4.1:

but I’m recently getting this communication error:
image

The binding does not seem to work with 4.0.0 nor with 4.1.0. Many have evidenced the issue, but no one has provided a solution. If you are using the e-welink/Sonoff binding, you are better off to stay on 3.4.5 until someone provides a fix.

1 Like

it worked until a few days ago, but now doesn’t anymore.
maybe it broke when I updated from 4.0.2 to 4.1M1

I have the same issue with Openhab 4.0.0 and 4.1.0

1 Like

anyone found a fix for device discovery ?!

Why my new instance of openhab is not loading the .jar from /usr/share/openhab/addons? it was working always :wink:

openhab-cli info
Version: 4.1.0-SNAPSHOT (#3639)
pi@host:/usr/share/openhab/addons $ ls -la
total 176
drwxr-xr-x 2 openhab openhab 4096 Oct 8 12:21 .
drwxr-xr-x 4 openhab openhab 4096 Oct 8 12:21 …
-rw-r–r-- 1 openhab openhab 165602 Jul 28 16:08 org.openhab.binding.sonoff-4.1.0-SNAPSHOT.jar
-rw-r–r-- 1 openhab openhab 70 Sep 25 07:33 README