Exec and HTTP commands don't work in rules

Hello, my first post here. Too many hours already spent on this, so need to ask you what I’m doing wrong.

I’m trying to setup some things based on HTTP protocol. I’ve configured Nginx+PHP server on the same Raspberry Pi. Works fine and it’s accessible. Got some items configured on top of HTTP binding and they works fine. HTTP binding is working properly.

I got some PHP script which needs to be hit every few seconds to do some things, no output required.
Since my HTTP cache entry configured in http.cfg is not being fired without items accessing it, I was about to create a rule to call a script on WWW server.

Here’s my approach:

rule cache_refresh	
 	Time cron "0/5 * * * * ?"
 	logError("cache_refresh", "START");
 	val results = executeCommandLine("curl", 5000);
 	logError("cache_refresh", results)
 	logError("cache_refresh", "OOOKKKK!!!!");

before that I was trying to use sendHttpGetRequest(HTTPString) instead of executeCommandLine() - rest no change. Then thing is that they are not being executed and returning unknown error.

In my logs I see only this:
13:13:05.199 [ERROR] [smarthome.model.script.cache_refresh] - START
13:13:05.264 [ERROR] [ntime.internal.engine.ExecuteRuleJob] - Error during the execution of rule cache_refresh: org/eclipse/smarthome/io/net/exec/ExecUtil

for HTTP the error is similar:
13:13:05.208 [ERROR] [ntime.internal.engine.ExecuteRuleJob] - Error during the execution of rule cache_refresh2: org/eclipse/smarthome/io/net/http/HttpUtil

No other errors/warnings are logged, no matter what I do. The rest of the script is not being executed after executeCommandLine/sendHttpGetRequest. I’ve tried different http links, no links and same error occur.

Cron works fine, rule is fired as expected and above errors are logged every 5 seconds.

OH2 freshly installed few days ago from image for raspberry pi.

I’m new in OH and these things are driving me crazy.