Exec-Binding 2.0 doesn´t work


I am new to Openhab. I found an example on how to use the exec-binding 2.0 but i can´t get it running. The script works fine if i start it from the command line.

Here is my config:

String schwippbogen { channel=“exec:command:schwippbogen:input” }

Thing exec:command:schwippbogen [command="/opt/raspberry-remote/tv.sh %2$s", interval=0, timeout=5,autorun=tru]

sitemap steckdose label=“Steckdose” {

Frame label=“Test”{
Switch item=schwippbogen label=“Schwippbogen” mappings=[on=“An”, off=“Aus”]


-rwxrwxrwx 1 openhab root 82 Feb 8 17:16 tv.sh

Can somebody push me in the right direction? I have no idea what is wrong.


Try autorun=true.

1 Like


I fixed that already. But it doesnt work.

is there a way to troubleshoot my problem? In the log files is no error shown.

Does the script work from the command line when you run it?

I think most issues when it comes to the Exec binding is due to permission issues and ensuring the user openhab has permission to run the file.

Did you use apt-get to install or manually? I think it is also recommended to place your scripts in “/etc/openhab2/scripts” which helps resolve the user permission issues I think.

If there’s no error in the log file it means either the script is not being run or it ran without error. You can get more information by setting the logging level of “org.openhab.binding.exec” to “trace”. See the documentation about how to do that:



it is working now. There was a problem with the rights for running the script.
I have on more questions. How can i pass a parameter (ON, OFF) to my script? So i can decide inside of my script what to do?

Thanks for your help.


it´s all working now. Thank you for your help.


Could you tell me, how you exactly you fixed this? I am streuggling aswell

Publish your things and items and we can have a look