Exec binding doesn't work

Hey there. I am new to Openhab2. I try to trigger a light with a 433 MHz plug, but i seems to not work.

My configuration:


Thing exec:command:apc [command="sudo /opt/rc-switch/switchOn.sh"]


Switch APCRunning { channel="exec:command:apc:run"}


sitemap default label="Hausautomatisierung" {
    Frame label="Funksteckdosen" {
        Switch item=APCRunning


[WARN ] [el.core.internal.ModelRepositoryImpl] - Configuration model '.things' is either empty or cannot be parsed correctly!


/opt/rc-switch/rcswitch-pi/send 11010 1 1

Load your .things file into Designer 0.8 and see if it is identifying any syntax errors or stray characters in the file. You Thing definition looks correct but the error is saying that OH can’t parse it which usually means one of these two problems exist in your file.

Thanks for your answer. I tried it, but there were no errors.

Hi Philip,

is you problem solved? How did you fix the issue? I am currently facing the problem that I don’t get my 433MHz devices connected correctly.