External authentication

I have stup https with external authentication. All is configured as found in wiki.
Netmask is correct.
However, when I connect to http://192.168.1.10:8080 or https://192.168.1.10:8443 from inside (ip falling in netmask range) the webpage asks for authentication.
A possible bug in 1.7.1?

What is your openHAB security property set to? It should be either External or None.

External is set

Weird. All I did was set up security to EXTERNAL and it no longer asks when I’m internal and I use the http address (it still asks if I use the https address though.

I didn’t set my netmask as the default matches my network. Try not setting the netmask or make sure it is of the form:

192.168.1.0/24

If there is a config error it would be there. If there is a bug, it would be there as well. Its the only thing that is different that I can think of.

This is in my conf file:

# configures the security options. The following values are valid:
# ON = security is switched on generally
# OFF = security is switched off generally
# EXTERNAL = security is switched on for external requests 
#            (e.g. originating from the Internet) only
# (optional, defaults to 'OFF')
security:option=EXTERNAL

# the Netmask to define a range of internal IP-Addresses which doesn't require
# authorization (optional, defaults to '192.168.1.0/24')
# security:netmask=192.168.1.0/24

I use 192.168.1.x internally for my devices.
However connecting from LAN through http or https always requests to enter credentials.

If you indent your lines by four spaces it won’t use the crazy formatting. Either that or highlight the lines and press the </> button in the edit box.

Perhaps the netmask part isn’t working right. Have you tried just leaving it default? (i.e commented out)

That is the only difference I see between our configs.

I wondered why the strange formatting appeared. Corrected this with 4 spaces (thanks for the tip!)
The netmask line is commeted out in my config

Please open a new issue rather than reopening a five-year-old issue.

Ultimately the answer to your question is outside of openHAB. It’s how the networking is set up on your operating system, which you didn’t disclose so there is going to be no way we can answer.

So when you do post a separate thread, please provide what operating system, how openHAB is installed, and how your networking is configured.

OK thanks.