Factory Reset in Habmin 1 for Z-wave

I’m trying to use Habmin1 for the configuration of my raspberry on z-wave network.
Everything works fine (controller identification, exclusion and inclusion), except that the numbering of the nodes is cumulatieve starting from last factory reset. So after a few ex- and inclusions it is difficult to keep track.

Is there a way to make this factory reset directly in Habmin1?

I’m not sure I understand what you mean - what does “the numbering of nodes is cumulateive” mean?

The controller has node number 1. And every added device will have a new number. When excluding a device this number is not used any more, so in the end you can have a numbering with many gaps.
So far, the only way I found to restart again and have a clean numbering (1, 2, 3, …) is to make a factory reset.

Yes - that’s the only way to reset the numbering. The controller will always use numbers 1 to 232, and will then re-issue numbers that have been excluded.

ok, is there a way to do this directly in habmin?

You mean to reset the stick (noting that this will completely reset your network). It’s been a long time since I used HABmin1, - there should be as the function is available in the OH1binding as well as OH2, but I’m not sure if it was added as a button in HABmin.

I think it could be useful. When setting up and testing my network, I often have to do a reset.

The “reset to default” button is not available in habmin1 (at least I have not found it yet :sunglasses: )
But I have that button in an older version of habmin2, running with openHAB 1.8.3 and it worked for me:

ehm…you are running habmin2 on OH1? Didn’t knew this is possible…

Any thoughts on that? Does it work flawlessly? Is habmin2 intended to run on OH1 or is it kind of a hack?

Do you think you can run this habmin2 together with habmin1 (using habmin 1 is important to me since it is part of the solution I would like to propose for the charting)

Habmin2 runs only on openHAB1 for older versions (mine is version 0.0.15 from June 2015).
I only had it installed a long time ago to have that controller reset button … other than that it has no advantages over habmin1.

Yes, it runs together with habmin1, let me see if I find the post about installing the two versions …
… search button works, here it is:

Please note that the mini tutorial was written for a manual install, if you have an apt-get install you need to use the folder
/usr/share/openhab/webapps/habmin and

ok, I will have a try with that.
Nevertheless, a simple button ‘Factory Reset’ would be nice.

Well …
I tried to have this habmin2 version 0.0.15 running without success.

Downloaded the zip file and unzipped the 100MB ( ! ) and put it in a folder habmin2.
(Didn’t change the addon jar, since habmin 1 is running fine)

Remark: it doesn’t surprise me that the link …:8080/habmin2 is not opening since I don’t see an index.html file in the root of the folder.

Back to my initial question.

Isn’t there a more gracieuse way to perform a factory reset in openhab? This can’t be that difficult, especially if a function already exists ?

I guess not then. The function to reset the dongle exists in the binding, but if it’s not available in the UI, then it might as well not exist as you can’t access it.