Factory-resetting Fibaro FGS 222 relay switches

Yeah I could try that, in case there any hints.

How big is the current relay?
sonoff 4ch is 45mm x 90mm X 40mm ( 1.7" x 3.5" x 1.5")

40mm x 37mm x 16mm

Quite a bit smaller. The Fibaros are the smallest on the market, I think.

You could also look at the shelly 2.5 which also drives two channels with 10A each.
But reading the shelly community it is no advised to constantly power something with it (e.g.) radiator pump for the heating that runs 24/7 - the shelly might overheat: https://www.reddit.com/r/homeassistant/comments/o5sf1t/shelly_25_overheating/

The heat pump definitely doesn’t run 24/7. Maybe 12-14 hours per day in summer at the absolute most. In any case, I think I’ll opt for a newer and hopefully more usable version of the devil I know and get the Fibaro FGS-223.

I’ve tried everything. The Z-Wave log is activated at the debug level, but unfortunately you almost certainly have to put the Z-Stick right next to the Fibaros, which means you’re not going to log anything. Trying to include them from openHab nothing appears in the log.

I’ve spent enough time on this.

The nightmare continues. The two FGS-223 relays arrived yesterday. I fitted one and included it on the first attempt. The “IN” terminal has vanished on this model, but apparently that doesn’t matter. However on the second the Q2 screw was completely stuck. After trying to dislodge it for an hour I gave up. I set up a return and ordered another, supposedly to arrive today. Today I find out that it’s due tomorrow. Why? Apparently “Premium” delivery means we’ll give it a go, but no guarantees. So I cancelled that and ordered another, for “urgent” delivery today, which supposedly is guaranteed. Sigh.

Why the urgency? Because my gas heating doesn’t seem to be doing anything. The floor is no longer heating. Somehow, the valve controlled by the relay that has not yet been fitted must have switched state from the boiler circuit to the heat pump circuit (just because I disconnected some wires?). But I’m not able to turn on the heat pump heating either, despite the fact that this is job of the relay that is fitted and, apparently, working. So I have to cross my fingers that it will work once both relays are fitted and working. Meanwhile, no heating of any kind, on one of the coldest days so far.

Hopefully I’ll have more luck fitting manual switches to these relays than to the other ones, so that at least I can activate the heating and cooling manually when all else fails.

You seem to have bad luck with those components. What kind of valve do you have? I could imagine that the fgs 222 is not designed for inductive load (which a valve usually is). In addition, closing or opening the valve (depending if it is normally opened or closed) will result in feeding the energy from the coil back to your circuit. That could lead to the problem that the contacts in the relay are getting welded together due to short current peaks

That’s a important thing. Always have a fallback for cricitcal systems like heating in case your home automation components fail

If I remember correctly, it’s a three-way valve that allows me to switch between the heat pump cooling, heat pump heating and boiler heating. When both switches are off, it defaults to the boiler circuit. I don’t have more details here with me, I’m afraid.

But in that case I would have experienced problems before attempting this whole reset procedure. The system has been running without problems for five years, almost always using the heat pump, but on at least one occasion I switched to the boiler, as indeed I did the other day when I lost control of the relays (both heat pump valve switches were in the off position at that point). Now it appears that one of the valve switches moved to the “on” position when I was attempting to fit the new relay last night - this is the only reason I can think of why the boiler would be heating water and yet failing to heat the flat.

I’ve made multiple attempts to fit manual switches, both momentary and toggle switches, with no success. That’s probably going to be a subject for another thread.

Now I think I have a bigger problem. I’ve just read that the FGS-223 model cannot be used as a dry contact relay, which I believe is exactly what I need for the valves/heat pump. The older model did have this option. This just gets worse.

I think I need the FGS-224. :man_facepalming:

All’s well that ends well. More tomorrow.

After ordering a new FGS-223 I realised that this model was no good, because I need dry contact relays (I stumbled on an e-commerce site completely by chance where they explicitly warned about this limitation). Fibaro had changed the specs. This explains why the “IN” terminal had vanished, and why, when I tried to test the one relay that I’d successfully installed, nothing happened.

With fifteen minutes to spare, I ordered two FGS-224 relays for same-day delivery. In this model, the dry contact option is back (though there is no power meter). I wired them up without any problems (the “IN” terminal is back), and included them in openHab fairly easily. The first one was included without being recognised, perhaps because I’d knocked the power back off at a key moment. On the second try it worked. Including and excluding seems much easier than for the FGS-222, and exclusion also does an automatic factory reset. The LED helps a lot.

I switched heating back to the heat pump, and it worked straight away. I still have to test the boiler.

I’ll have a go at reviving the old relays by connecting just the L+N wires and connecting them to a switched socket so I can easily turn the power on and off.

One thing I’ve always wondered: why are there three switch channels for these relays in openHab (switch_binary, switch_binary1 and switch_binary2)? switch_binary and switch_binary2 seem to be the “real” ones, so what’s switch_binary1?

The docs only mention switch_binary1 and switch_binary2.

I’ll hook some test items up to the switch_binary1 channels to see what they do.

Answer: switch_binary1 doesn’t seem to do anything.

I have a handful of FGS-223 switches and they only have two channels, binary_switch1 and swwitch_binary2. They have been working ok and no major issues doing a factory reset (sometimes a few retries are needed before it takes effect) as I can recall.

That said, I’m not spending any more money on Fibaro devices due to this issue:

Take a look at the Heltun High-load switch based on the Z-Wave 700 series chip. It’s an in-box relay. Sounds like it may be a good fit for you since it’s designed for… high load. It can be firmware flashed to any region. They also make a 5-channel relay in a single package (Quinto). I’m about to try that with OH for a junction box with 4 light switches inside (rather than two double switches)

Aeotec, and Zooz both make in-box relays.
Zoos just released a new, very compact 700-based double-switch. It has a wire pigtail and an internal antenna which isn’t my preference in most situations, but their sales rep said that they did market research showing that most installers (not DIY’ers) want pigtails.

I think, when I briefly installed the FGS-223, that I also got three switch channels. Odd.

I haven’t had any problems with the Fibaro sockets yet. Four years and counting.

I appreciate the tip but I now have everything working with the FGS-224 relays.

I have similar issue with factory resetting 4 of my Fibaro Relay switches? Is the problem solved?

I never managed to revive them. I’ll have another go at some point, but the solution for me was buying the FGS-224 relays. :man_shrugging:

Thank you for your reply. I am in touch with Fibaro let me see what I can do.